Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Justify paragraph in Swedish creates havoc


Recommended Posts

Recently I have moved on from PagePlus to Publisher and come across a serious problem which I did not have with PagePlus. When inserting a text (in Swedish) in a text frame, justifying a paragraph creates a number of rows where a single word is spread out with long distances between the letters. Please see the attachment. I suspect it has something to do with that Publisher does not recognise the Swedish language, because the automatic hyphening doesn't work either. There are several Swedish dictionaries available online, but there is nothing in the help file to explain how one can incorporate them. I would be most grateful for a work around. or else I may, regrettably, have to revert to PagePlus.

With many thanks in advance,

Örjan Widegren

10.03.2020_11.38.41_REC.png

Link to comment
Share on other sites

For how to add your own dictionaries to Publisher:

 

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.5 (.1342) and 2.0.0 / Affinity Designer 1.10.5 (.1342)  and 2.0.0 / Affinity Publisher 1.10.5 (.1342)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.5 (.280) and 2.0.2 / Affinity Designer 1.10.5 (.21) and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

Thank you very much for taking the trouble to advice me. But when I have done exactly as is explained in the FAQ, neither spelling nor the hyphonisation work. In the text panel the Swedish language is recognised, but the spelling appears to be English (although I have changed it to Swedish) and the automatic hyphonisation soesn't work at all.  What do you think could be the problem?

Örjan

Link to comment
Share on other sites

I'm not sure what might be wrong, Örjan.

Can you upload a sample document that shows the problem, for us to look at?

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.5 (.1342) and 2.0.0 / Affinity Designer 1.10.5 (.1342)  and 2.0.0 / Affinity Publisher 1.10.5 (.1342)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.5 (.280) and 2.0.2 / Affinity Designer 1.10.5 (.21) and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

Thank you for the question. I have now updated Publisher to the latest version and installed the Swedish spelling and hyphening dictionary. I have asticked automatic hyphening, but still the result is as attached. When ticking the spelling and suggest alternatives, virtually all the Swedish words are considered misspelled. Any ideas about how to resolve this issue are most welcome.

Örjan

 

Hyphoning problem.afpub

Link to comment
Share on other sites

Thank you very much indeed. It seems obvious that the hyphening doesn't work in my installation of Publisher. But why? I have placed the language files in the same map as you showed, and the Swedish language is now recognized by Publisher according to what is shown in the Character panel (see attachment). I have indicated automatic hyphening (see attachment). The language files I have obtained from GitHub. Those I have also attached, in case it is something wrong with them. 

Thanking you very much in advance

Örjan Widegren

 

25.03.2020_09.57.55_REC.png

25.03.2020_09.56.15_REC.png

hyph_sv.dic sv_SE.aff sv_SE.dic

Link to comment
Share on other sites

1 hour ago, orjwid said:

It seems obvious that the hyphening doesn't work in my installation of Publisher. But why?

Does this mean that Swedish spelling is working properly now? And you're only having a problem with the hyphenation?

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.5 (.1342) and 2.0.0 / Affinity Designer 1.10.5 (.1342)  and 2.0.0 / Affinity Publisher 1.10.5 (.1342)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.5 (.280) and 2.0.2 / Affinity Designer 1.10.5 (.21) and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

Thank you Lagarto so much for taking the trouble to help me. As I am editing Bahá’í-Nytt,  the newsletter of a Faith community in Sweden, it really matters a lot for me to get this problem straight. It appears that there are some files that I don't have, especially description.xml and dictionairies-xcu. The files sv_FI.dic and sv_FI.aff are, I guess, specific for a Finnish dialect of Swedish, which is not important for me. If you still have those files at hand, I would be most grateful if you could send them to me: orjwid@zoho.com  I find GitHub somewhat challenging to deal with. 

As regards pointing to the language dictionary, it turns out that when in Preferences>Tools the language dictionary is pointed to C:\ProgramData\Affinity\Publisher\1.0\Dictionaries, Publisher recognizes the Swedish language on the Character panel (see attachment), but when it is pointed to  C:\ProgramData\Affinity\Publisher\1.0\Dictionaries\sv-SE, the language is listed as unknown  (sv-SE) and when I on the text panel klick check spelling, an error message appears, stating that there is an unknown language sv-SE for which no dictionary is installed. In either case neither spelling nor hyphening works.

Many thanks to Walt Farrell also. The spelling doesn't work at all, all the Swedish words are regarded as misspelled. ,

- Örjan

25.03.2020_20.27.45_REC.png

25.03.2020_20.36.14_REC.png

Link to comment
Share on other sites

44 minutes ago, orjwid said:

As regards pointing to the language dictionary, it turns out that when in Preferences>Tools the language dictionary is pointed to C:\ProgramData\Affinity\Publisher\1.0\Dictionaries, Publisher recognizes the Swedish language on the Character panel (see attachment), but when it is pointed to  C:\ProgramData\Affinity\Publisher\1.0\Dictionaries\sv-SE, the language is listed as unknown  (sv-SE

That setting must point to the Dictionaries directory, not to a language directory.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.5 (.1342) and 2.0.0 / Affinity Designer 1.10.5 (.1342)  and 2.0.0 / Affinity Publisher 1.10.5 (.1342)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.5 (.280) and 2.0.2 / Affinity Designer 1.10.5 (.21) and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

  • 2 weeks later...

Thank you so much for all valuable comments. However neither the spelling nor the hyphening still works. I have now reinstalled Publisher, but the spelling and hyphening still doesn't work. The Sedish language is recognized on the Character panel, both for spelling and hyphening. But when I klick on Check spelling only the first word is affected by red underlining. When I in a Swedish text ask for show spelling options the next word is affected but now options are stated. When klicking on next, the nest correctly spelled Swedish word is listed but no options, etc. When I klick on check spelling when typing, all the words on the page are underlined in red. Can this strange behaviour give a clue to what is wrong?

Thanking you in advance for your ideas.

Örjan

Link to comment
Share on other sites

  • 1 month later...

Dear Lagarto,

I thought I had Thanked your for this last help, because now the Swedish spelling and hyphening works flawlessly! It was really important for me to solve this problem, for a desktop publishing program that cannot handle one's language is not useful. I think Affinity should handle this language issue as a priority!

Örjan

Link to comment
Share on other sites

  • 2 weeks later...

I tried to look for hyphenation dictionaries in Swedish among those Hunspell dictionaries, but I must confess I didn't understand much. I couldn't find any downloadable file - for macOS that is. I also tried to install the same dictionary for OpenOffice, only it wasn't a dictionary, but an extension which installed itself to NeoOffice which I have. And that doesn't help much. 
So yes, it would have been nice if there could be something like what orjwid suggests - I could even accept more clicks than one, but at least some pointer to an installation file. 
But of course, if someone can explain to me where I find the files needed - but then they must be downloadable - I guess I might manage to install them in the right place. 

By the way, there was some suggestion that one could set the language in the System Preferences in MacOS, setting the spelling control to the chosen language, but that affects everything I write on the computer, which is very inconvenient as I use four languages on a daily basis, so I prefer to have that option set to Automatic. 

Link to comment
Share on other sites

12 minutes ago, Lagarto said:

Please check my post as of April 6 in this same thread, it has an attachment for Swedish dictionaries, and installation instructions.

Great! Thanks a lot and sorry for not having seen that earlier.
The only thing now is to get the instructions on how to install it for macOS:) There were a lot of elements in that package, so I am not sure where all should go. The read-me's seem to be for OpenOffice and that doesn't help. If you don't know where to put what on a Mac, perhaps some others know?

Link to comment
Share on other sites

6 minutes ago, Wilfred Hildonen said:

The only thing now is to get the instructions on how to install it for macOS:)

 

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.5 (.1342) and 2.0.0 / Affinity Designer 1.10.5 (.1342)  and 2.0.0 / Affinity Publisher 1.10.5 (.1342)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.5 (.280) and 2.0.2 / Affinity Designer 1.10.5 (.21) and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

Yup, thank you Lagarto, it is all in place now and appears in Affinity Publisher. The only odd thing is that it says Svenska (El Salvador), and as far as I know, they speak Spanish there and then some Indian languages, but not Swedish :)
Anyway, I guess that doesn't matter. It works! Thanks again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.