Jump to content

Recommended Posts

Very new to Affinity, purchased all three.  Been working in Publisher laying out a magazine style doc, then went to export what I have to PDF and everything fell apart.   I choose PDF - Print and deselected bleeds.

The software can't be this buggy, can it?  I'm really hoping I've got something set wrong.   See attached files.  1 is just text wrapped around a transparent PNG, 2 is drawings done in Designer (from Publisher).  Please help!  People are waiting to see progress...

02.jpg

01.jpg

Share this post


Link to post
Share on other sites

Ouch! 

@chrisborgman Any chance you can upload the .afpub document, or a sample version so we can see first-hand what's happening on export.


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

I can't right now, but I'll put together a public doc.  It's seems to be the Presets that are making a mess of this.  If I don't select any Preset, it works, probably because everything is getting flattened and converted to CMYK, or at least it looks like it's getting converted by the color shifts.

 

I'm working in sRGB and want to export a PDF for web (sRGB) but so, far, I can't do that.

Share this post


Link to post
Share on other sites

You could ask a mod to generate a dropbox link so it can be off forum and they could take a look see.


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

Many thanks for your files - I've opened your PDFs in multiple different PDF readers/editors and in each it appears correctly.
It seems as though Apples Preview is the only app that displays the PDF in this manner, and interestingly enough the thumbnail shown for the page in Preview is correct -

image.png

I'm unsure currently for the exact reason for this, so I'll log this file with our QA/Development and respond here ASAP with any information we find :) 

Share this post


Link to post
Share on other sites

I've spoken with our QA team and we believe we've identified this issue - it appears to only affect PDF's in preview when they're exported to RGB/16bit. Converting the document to RGB/8bit and exporting again provided a PDF that looks correct in preview and elsewhere.

I'll log this bug for further investigation, to see if this is something we can fix whilst writing the PDF, as if the error is introduced with Preview then unfortunately it will be for Apple to fix.

I hope this helps!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.