Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Becoming frustrated by sooo many bugs

Recommended Posts


I started to use Affinity Photo for painting on the iPad lately and I am really surprised that is contains so many annoying issues.

The reason I started trying AP is that Paolo Limoncelli / Daub, whose brushes I love in ClipStudioPaint, was raving about AP's new brush engine and offered nice brush sets for it. So I went ahead and bought AP and the brushes. And also Frankentoons nice Neptune Kit.

And indeed, AP's capabilities look promising. But working with AP feels like using beta software, really. Below I am listing a couple of the issues I am repeatedly seeing.

1. When changing to a different brush and starting to paint often AP will start a straight line from some random point to where the canvas is touched with the pencil. This cannotbe undone with undo, but only by selecting an older state from the timeline. Also if for some reason it is not immediately recognized and you see the line only later, it needs to be removed manually, because the painting has progressed in the meantime.

2. Sometimes when changing to the browser to search for a reference without having saved explicitly, the previous changes to the painting will just be "forgotten".

3. Resize rectangle for selection disappeares without reason

4. Playing a macro (when editing a photo this time) pretty often crashes the app. The same macro will not always crash the app, though.

5. Doesn't support iOS' screen split (ok, no bug, missing functionality)

6. UI elements continue to be shown (layer rectangle when trying to move a layer). Needed to stop and restart AP to get rid of it.

7. Ignores changes to brush settings (tried changing the associated tool of a brush to "erase", which had no effect)

8. Sometimes toggles off controls when I just select a tool, like erase or brush.

9. If I really switch off controls intendedly with the icon at the top right, they will  come back pretty soon on their own

The above list only contains those issues I noted down after really becoming frustrated. There might have been more.

The last update to AP is 2 month ago, any chance of getting an update to a more stable version soon? I do not think I want to use the software as is more.

In addition to the above bugs I think the intuitiveness of the UI needs to be improved as well. Just a few examples of functions were I needed to search on the net, which I did not need for any other painting program for such basic functions ever:

- Naming a layer

- Removing a layer group which was mistakenly added (only possible via timeline, or maybe I did not even find the intended way)

- Picking a color (reference spot is under the finger, instead of being slightly shifted and seeing the actual place in the picture to choose from)

- Selecting and working with the selection (changing personas all the time, argh)

The above might sound harsh, but I have used multiple painting apps now (CSP, Artstudio Pro, Sketchbook, Paintstorm Studio, MediBang Paint) and AP feels almost as being the least mature. PSS is not really ideal also, but hasn't crashed or malfunctioned as often as AP did for me.

I saw that there is a sub-forum to report bugs, but with such a long list, I really do not feel like doing for each individually. All of them should be easy to reproduce. Feel free to move to that forum if more appropriate.

Environment: iPadOS 13.3, iPad Pro 12.9 latest gen.



Link to comment
Share on other sites

  • 2 weeks later...
  • Moderators

Hi @FrayingCanvas,

Welcome to the forums. 

  1. Any actions should make it into the history panel, and you should be able to undo any actions. If that's not the case, can you attach a screen recording of your workflow with "Show touches" turned on in the App's General Preferences.  
  2. Screen recording required to replicate this
  3. I'm not entirely sure what you mean by this
  4. Which macro?
  5. n/a
  6. Screen recording required to replicate this
  7. I replicated this and logged it with our developers. 
  8. Screen recording required to replicate this
  9. Full screen mode can only be "turned off" by pressing the button or by rotating the tablet (portrait to landscape or vice-versa)
Link to comment
Share on other sites

Thanks @Gabe for your answer.

1. Thanks, @frankthechicken for already uploading a recording.

2. Was able to reproduce in a few seconds by (a) doing a change to a painting and then (b) just switching to a couple different apps before going back to AP. When doing so, AP showed the initial splash screen and then as expected all changes were gone.

3. Will try to find easy to describe steps which cause this.

4. Instant 70 by https://www.thefxmonkey.com/

6. This was after editing the name of a layer. The textbox with the name just did not disappear after the renaming.

8. Just reproduced (again in a few seconds) by clicking with the Apple Pencil on the paintbrush icon and withouth selecting anything from the paintbrush submenu clicking on the eraser icon. After that,I unintendedly was in fullscreen mode.

9. That is definitely not true. Very easy to reproduce: Click the top-right icon to switch fullscreen mode on.Then just click or draw a few times with the Apple Pencil onto the canvas and rest your palm a few times on the screen.

As I already said, I think you should be able to reproduce in a small amount of time. That is why I said it feels like beta software. I would have expected your QA to find bugs this easy to trigger before release.

Link to comment
Share on other sites

  • Moderators
  1. I managed to replicate it now and logged it with our developers
  2. This sounds like the app got closed while switching between the apps. You've not attached a screen recording illustrating this though. 
  4. I cannot replicate this. We are going to need exact steps or screen recording of your workflow. 
  5. -
  6. What you describe is different than your original issue (UI elements continue to be shown (layer rectangle when trying to move a layer). Needed to stop and restart AP to get rid of it.) Which one are we investigating? Still, no screen recording or steps how to reproduce it. 
  7. -
  8. Logged with our developers. 
  9. Logged with our developers. 

Next time when you report a bug, please follow this guide: https://forum.affinity.serif.com/index.php?/forum/71-bug-reporting/

Link to comment
Share on other sites

2. Correct, iOS likely closes it to manage memory. Loosing all work because AP does not handle that case correctly still is a bug.

Just tried the same with CSP right now. Not only can I switch between as many apps as I want and when coming back, the drawing is still there (CSP seems to prevent being closed when there is unsaved work), even if I actively close the app by swiping it up and it reloads with splash screen afterwards, the (unsaved) drawing is still there.

*That* is robust behavior.

3. Tried to reproduce and I think what I saw was likely unintuitive behavior of lasso selection outline vs. layers becoming deselected without me noticing.

I will add a short recording soon.

4. Screen recording attached.

6. Screenshot attached. Unfortunately I did not have screen recording running when this happened and couldn't yet reproduce again. What I did was just moving layers around for a while.

I think it has happened for both: renaming a layer (with the textbox staying on the screen until AP is closed) and moving (with the layer image staying until close).

Next time when you report a bug, please follow this guide: https://forum.affinity.serif.com/index.php?/forum/71-bug-reporting/

Can you explain what you mean?

I have given simple to follow steps for issues being reproducible in a few moments. Screen recordings can help understanding certain harder to describe issues, but even in your references article are not mentioned as mandatory (which I think is right).

For some I have now added screen recordings / shots, but e.g. for 4. e.g. it takes only clicking between a few different setups of the Instant 70 macro pack to kill AP. Not sure why you were not able to reproduce yet yourself without a recording.

The majority of the bugs I reported are easy to reproduce in just a few moments. 

As the title says, I was (am) frustrated by how little robust the app feels and surely do not feel to do your or your QAs work.


Link to comment
Share on other sites

  • Moderators
46 minutes ago, FrayingCanvas said:

Can you explain what you mean?

I have given simple to follow steps for issues being reproducible in a few moments.

You've not given any steps. Look at your first post. This for example.


On 12/25/2019 at 10:45 PM, FrayingCanvas said:

Playing a macro (when editing a photo this time) pretty often crashes the app. The same macro will not always crash the app, though.

But that's not what you're doing in your video. You're creating a new document, and play 2 macros on an empty document. That's a completely different recipe. If you were to give the relevant information in your first post, we would have found all the issues from that, not just 1...


I've logged the macro issue and we're already aware of the ghost layer staying on the screen :)

Link to comment
Share on other sites

As I said, the long list really annoyed me and made me only describe the issues shortly in my first post. frankthechicken being able to immediately recognize issue 1 shows the descriptions were not useless rants only.

That you now were able to reproduce all issues, most of them with the short descriptions in my 2nd post, proves my point that the bugs are not hard to trigger and QA should have found them.

Besides the "selection and move tool" weirdness, for which I will provide a recording the next days, I think all bugs are now in your bug-tracker, which is good. Hopefully they can be resolved soon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.