Jump to content

maxsteenbergen

Members
  • Content Count

    30
  • Joined

  • Last visited

Everything posted by maxsteenbergen

  1. Using OpenGL instead of Metal and increasing the RAM usage Limit makes AD usable again.
  2. @ronnyb I have 16GB of RAM available. The 2GB is the graphics card’s memory, enough to adequately render some moderate 3D work. Besides, the 1.7 beta and earlier ran like a dream.
  3. You’d think 16GB for just AD and no other apps running would suffice....
  4. As mentioned here, I have a document with 115 artboards (all 99x99 icons) that gets very slow to work with. Specifically, I found the RAM usage to be fairly huge right from the start, with large jumps when opening and editing docs. Opening AD: 1.11 GB Opening the document: 1.8 GB Zooming in the document just 1 step: 2.5 GB Additionally, it seems like macOS's WindowServer process is affected as well, rising up to 1.2 GB. Affinity Designer 1.7.1 (MAS version) iMac (Retina 5K, 27-inch, Late 2014) 4 GHz Intel Core i7 16 GB 1600 MHz DDR3 AMD Radeon R9 M290X 2 GB
  5. I'm finding 1.7.1 to be slow as heck too. I've got a document with 115 artboards (all 99x99 icons) and after a short while simply selecting and editing paths gets tedious. Also, it sends my fan flying. AD uses 1.05 GB of RAM immediately after startup, rising to 2.25GB after opening the document. Switching between Metal and OpenGL doesn't seem to make much of a difference. iMac (Retina 5K, 27-inch, Late 2014) 4 GHz Intel Core i7 16 GB 1600 MHz DDR3 AMD Radeon R9 M290X 2 GB
  6. I noticed Illustrator's Blend tool is one the Roadmap a well. Is that planned for 1.7 as well, and will it allow us to have gradients follow an arbitrary path?
  7. Is there a way for Affinity Designer and Affinity Photo to sync their brushes? Now I had to import one brush set to each application separately.
  8. NINJA EDIT: Just downloaded Beta 3 and that does open the file. Can the devs indicate what the problem was/is so we may avoid it for the time being?
  9. I have yet again a file that won't open anymore. I noticed some elements didn't align like they should, so I save the file, restarted AD and opened the file. Unfortunately, it immediately crashes. I've had this happen before when working with a fairly large bitmap embedded in the file (see the linked topic). This time around, even though there's a bitmap in the file, I wan't editing that layer specifically and it isn't all that large. @MEB Could you work your magic again and ask one of the devs to repair the attached file? I'd hate to start over. concept3.afdesign
  10. I'd say those chances are negligible. I run all my machines in the English localization, and the crash occurred after copy/pasting a rather large image embedded in the document.
  11. Hi Miguel, Thanks so much for the fixed file. Do you know what might have caused this?
  12. Sorry to keep bugging, but I really need an answer on this. This is client work so having to stall any longer is not really an option.
  13. Hey MEB, I totally get that you're understaffed these weeks and that the file may not be recoverable, but just for my planning, are you talking hours, days or weeks?
  14. I'm working on a site design and as I was copy/pasting a group, Designer crashed immediately. Fair enough, seemed like a random thing but now every time I try to open the same file Designer crashes immediately. Same thing happens in Photo, as expected. Do I now have to start from scratch, or is this file (attached to this post) salvageable? I'm running AD 1.6.0 on macOS 10.13.2 site_mockup.afdesign
  15. I'm making some icons at small sizes (~ 24x24px) and noticed that expanding the stroke of a circle results in odd, wobbly paths. Looks lime some kind of rounding issue, since the larger the circle the less noticeable the issue gets.
  16. I'm making a set of icons in SVG format, and have them all on their own artboard in 1 document. Exporting an artboard to SVG (with no border or fill) includes a <rect> tag named like the artboard. I'd expect the artboard to just set the width/height & viewbox properties of the export, not to have its own rect path. Maybe this could be just a checkbox in the export options?
  17. What the title says really. Steps to reproduce: Create a new Assets category -> Rename the category -> Crash. The renaming is successful though; it is there upon app relaunch
  18. Thanks, I can confirm the beta has this fixed, though not for the SVG (flatten) preset
  19. I was making some simple icons in AD for use in our applications. Since we use SVG sprites and set fill & stroke through code, I removed both in AD and exported —what I thought would be— an SVG file with just the path coordinates. Unfortunately, all I get is an empty SVG file. The doctype & svg tag is all there, but the actual paths/shapes are missing. This is easily reproducible by drawing a simple primitive shape, disabling the stroke & fill colours and then exporting to SVG.
  20. I'm following an online course that comes with a supplied .abr brush file. I've tried importing it into AD (using Pixel Persona), but doing so consistently crashes the app. I've attached the crash log. crashlog.txt
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.