Jump to content

ZufDraw

Members
  • Posts

    99
  • Joined

  • Last visited

Everything posted by ZufDraw

  1. Still an issue, I use this tool intensively but sooner or later it is impossible to copy the layer with the perspective filter. I isolated one of my documents with this issue and it isn't even related to a group necessarily. Just try to copy this layer and you'll see what goes wrong. If I create a brand new rectangle and apply a perspective filter to that, it works fine. But the filter layer contains the copy bug used to contain a lot more content and it's beyond repair now. I even tried to save a duplicate version of the file and copy/paste layers between documents but the issue remains. BTW I'm on a Mac. AP 1.10.4 MacOS 10.15.7 Perspective filter copy bug.afphoto Perspective Filter copy bug 2.mov
  2. It's kinda quiet here. I hope a nice new version is in the works. I check this forum too often hoping for an update for the pen behaviour - jagged lines on low zoom (<50%)levels and the overall line bugs -. We use affinity professionally on a daily basis (6-8 hours a day) and this is our number 1 - by far - improvement request.
  3. A friendly bump for this issue. I know it's been only 2,5 months but something tells me this could be quite simple to fix. Also, the jagged line thread was closed(?), I wasn't able to reply to that thread anymore, but that's an equally annoying issue especially for us hand drawing artists. In short: when zoomed out more than 50% quick strokes become jagged.
  4. AHHHH. same here. AP 1.10.1 OSX Mojave MBP 2018 A file I was working on all day. No problems.. suddenly this issue. I think it is related to editing an embedded Designer document... [edit] this was definitely the case. I dropped a design document to my AP document. It shows up as "embedded document"layer. I can freely edit that embedded document (it opens a new window), but AP does cannot save. For test purposes, I tried to copy that embedded document and paste that into a new document I can see it is scrambled/incomplete (layers missing). I cannot save my AP document with this embedded document. When I delete that layer it saves fine... [edit2] it looks fine when I 'place' the document [edit3] unfortunately it also fails with the placed document. As soon as I edit anything in the embedded document, AP can no longer save. It doesn't matter if I close the embedded document or not.
  5. Is there anything more you could tell. Can we expect this to be fixed -eventually- since it is 'logged'. Is this some kind or priority or is it on a long list of "whenever there's time left". Is this hard to do and therefore will take some time or is it an easy fix. Anything. For me it's critical so would appreciate a little more indication of what to expect.
  6. I wasn’t clear with what I meant with lines. With Lines i mean the outlines (Also referred to as ink lines in cartooning) of a hand made drawing (so pixels, not vector). Just simple objects, people, buildings, nature, vehicles all drawn by hand (on a cintiq). Coloring is just like you would colour a coloring page, only more detailed and layered. Here is a small corner of a drawing I made (on low resolution). E.g. the people might all need to be colored Ps @Old BruceI posted a feature request
  7. Thanks I was aware of that workaround. That’s fine for a single instance, but I in my work I make manual drawings and when I colour the drawing (in Ps) I use the bucket a lot, like a 100 times or more so I would prefer to just click and fill in 1 go with the flood fill. The circle example was to illustrate the issue. In practice I’m working with hand drawn images. I was just wondering if I was missing some option, since the select tool is able to sample all layers so I assumed the flood might be set in a way to do that would too. Your replies confirmed it can only sample layers below. To me it seems like a strange limitation though. I mean, if you colour any line drawing, wouldn’t you always have the colour layer below the line layer. The similar bucket tool in ps is able to sample all layers. You cannot even limit it to only the layers below(?). There’s probably some other (photo editing) reasoning behind this choice that would make other things easier, but for coloring line drawings it’s tedious.
  8. Thanks @stokerg, I'm sorry I was unclear. I'm talking about AP. I want to flood fill to work with the contraints from all layers. So let's say I have a circle (line, no fill) and want add a layer below that circle to fill that circle with colour. I cannot seem to use the flood fill tool to fill that layer within the constraints of the layer above.
  9. Thanks for the confirmation. I tested with a mouse on my MBP and it's the same. Maybe you have different os versions on your iMac (I do ;-))? These are my settings
  10. Ok strictly speaking not a bug(?), but this does not work as intended I assume. In OSX when you scroll through the layers list and happen to hover over the scroll bar, this scroll bar appears. This is linked to an OSX setting (show scroll bar is set to automatically) which I prefer above the "show always". IMO it should not cover the layer selection as follows: OSX Mojave MBP2018 AP 1.9.3
  11. At some time flood fill was only available for the current layer. Then they implemented it for all layers + below. But it is still missing the option to sample ALL visible layers (so also the layers above) Which, imo, is much more useful than just the layers below. Could you please add the option to sample ALL layers in flood fill.
  12. Aaah, I see. So you can select a group of objects and drop colours on them. And I guess to be consistent it also fills any pixel layers as a 'side effect'. In itself it seems a bit odd to fill a group of pixel layers with the same colour (even when you select "stroke" in the group fill, the pixel layer still is completely filled since there is nothing to be stroked) but since it does the same to specific objects I get why you are able to 'fill a group'. All in all it might have been more logic/consistent if A a single selected pixel layer would receive a fill with the colour picker and when selected through the group or B a single selected pixel layer does not receive a fill with the colour picker but also not when selected through the group In contrast, the gradient tool seems more consistent. You can fill multiple layers with group selection and it works the same on a single layer. Anyway, I'm splitting hairs here. Im fine with the way it works. Thanks for explaining!
  13. Aha, ok I now understand you need to select an object with a 'fill property', like an ellipse. So the only thing I don't get yet is why it fills my whole layers when I have a group selected. That made me think I could also just select the layer and fill it, which I can't (and don't need). I don't understand why one would want to fill all sub layers of a group with a colour, discarding all content. Anyway, my issue was I don't want to fill these layers, I just want to pick a colour for further useage and I now know how to do that. dropper.mov
  14. Thanks! that fixed this issue. Still, I'm not sure what this option is supposed to do, it only seems to work on groups. If I select a single layer/object, it doen't seem to do anything
  15. when I color pick a colour when a group is selected, all the layers below get filled with that picked colour. OSX Mojave MBP2018 AP 1.9.3
  16. Is there a way to have the flood fill tool work with all layers? Currently it only seems to works with the (current layer and/or) layers below. I would like it to also be constrained by the layers above the current one.
  17. I have the same here. The flood was Super slow. It has improved a lot lately, but it is still slow compared to PS
  18. It seems something is wrong with the selection in 1.10. Or it maybe I missed a setting. Check this test file. In 1.9, If the upper layer is selected and I click on the dot, the lower layer gets selected. In 1.10 this does not (always) work. The upper layer is treated as a complete fill. It seems it is impossible to select 'through' upper layers. Selection Bug.afphoto
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.