Jump to content
imfastrnu2

Affinity Designer Cropping Tool Not Working

Recommended Posts

Recently I've been having trouble with the cropping tool in Designer. It was working very well before but now it's not working at all.

I"ll open an image file that I need to crop, select the crop tool, go to the blue bar at the top-middle and try to drag down. But I no longer get the up-down arrow key and in the rare occasion that I do, it doesn't actually drag down. It also fails to drag from any corner or draw a new rectangle.

In a possibly related issue, the middle mouse button pan no longer works. It doesn't even give me the grab hand. And, believe it or not, even using the spacebar will not allow a pan. It will show the hand but won't actually drag the view.

I feel like there's something that needs to be purged. Preferences maybe?

I'm running the latest version 1.7.3 on Windows 10

I've tried reinstalling. Nothing is working here. Any thoughts?

Thank you

David

Share this post


Link to post
Share on other sites

If you’re running a 1.7.3 version then that’s – at the time of writing – one of the betas (best to give the exact version number) and not the current production release.
Betas may contain problems that aren’t in the production release.
Issues with the betas should be posted in the relevant beta forum: https://forum.affinity.serif.com/index.php?/forum/33-designer-beta-on-windows/
Doing so makes it much clearer that it’s (probably?) not a problem with the current production release.

Share this post


Link to post
Share on other sites

This was happening on version 1.7.2 as well. I thought going to 1.7.3 might resolve the issue but it had no affect.

The version is 1.7.3.481 and it gave no indication when downloading it from my control panel that it was a beta version.

Share this post


Link to post
Share on other sites

Which control panel did you download 1.7.3 from?
To my knowledge the betas are only available by downloading from the forum.
The betas do tell you that a new beta version is available but they redirect you to the forum where there are plenty of warnings.

Share this post


Link to post
Share on other sites

P.S. You can choose what settings to reset by using Preferences/Miscellaneous. You can also wipe settings by holding CTRL down while you start Designer but that’s more ‘drastic’.

Share this post


Link to post
Share on other sites

The 1.7.3 updates are now available, if you close and reopen your apps it will check. The updates should also be available soon on the Windows and Mac App Store.

@imfastrnu2 I can't seem to reproduce your issue with the Crop Tool in Designer on an image. If the reset doesn't work can you perhaps do a quick screen recording.

Share this post


Link to post
Share on other sites
16 minutes ago, Lee D said:

The 1.7.3 updates are available, if you close and reopen your apps it will check. The updates should also be available soon on the Windows and Mac App Store.

@imfastrnu2 I can't seem to reproduce your issue with the Crop Tool in Designer on an image. If the reset doesn't work can you perhaps do a quick screen recording.

Yes, Here is a quick video. Let me know if you need to see more.

 

Share this post


Link to post
Share on other sites

Hmm… Something strange is going on here.

Your “Background” layer is locked, which I would have expected to stop the crop function from working but I’ve just checked in 1.7.2.471 and it doesn’t. The help says that locking a layer “prevent(s) accidental selection and transformation” which I would have thought would include cropping (it’s a “transformation” and “selection” was possible) but apparently not. I think that needs to be looked at by the developers to see which behaviour is expected, i.e. should a locked layer be open to cropping? (Checked with the 1.7.3.471 production release and it’s still the same.)
Why you, specifically, can’t crop in this situation is another – maybe related – issue. We need to know whether cropping should be allowed before saying whether what you saw is a bug or not. In other words, why is cropping allowed on a locked layer and, if it should be allowed, why wasn’t it working for you? Over to the devs for that one.

As for the panning not working, I don’t know. Maybe it’s related to the first issue but there’s no easy way for me to tell.

P.S. I’m still curious as to how you downloaded the beta and which “control panel” you used.

Share this post


Link to post
Share on other sites

Garry,

I'm not sure what to tell you about the download, I simply went to store.serif.com, logged into my account and went to the "Downloads and Product Keys" under the "Your Account" icon in the top right. From there I scrolled down until I found designer and it was listed as 1.7.3. So I downloaded and installed it and it was version 1.7.3.481. I'd give you more details if I could but that's really all there was to it.

BTW I noticed the layer was locked and in the video it is indeed locked, however, even when I unlocked the layer nothing changed. So locked or unlocked it still didn't work. 

Resetting everything did though. So I don't know what was happening but getting it all back to "out of the box" did the trick.

Dave

Share this post


Link to post
Share on other sites

I think the confusion over the beta is probably just a numbering/timing issue.
The last Designer 1.7 beta released on 25th September was numbered 1.7.3.481.
However, on Monday the latest production release came out, also, handily, numbered 1.7.3.481.
But, the email telling me about the 1.7.3 production release didn’t get to me until 2.30PM Tuesday, which was about an hour after I said that 1.7.3.481 was a beta.
So the version you downloaded (if you downloaded it before starting this thread) will have been the production release, I just didn’t know that it was by then the release version.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.