Jump to content
Sign in to follow this  
amedeomantica

Artifacts rasterizing an image clipped inside a rectangle

Recommended Posts

Hi,

I'm experiencing this issue: I have an image clipped inside a rectangle (mask), and the rectangle also have a stroke set.

When exporting, or rasterizing the layer artifacts appear on the image edge, it looks like there is some computation error in the subdivision.

To reproduce just open the attached Test.affinity and export in Tiff with default settings.

Additional info, the issue happens when the clipping mask stroke is set to be inside, see stroke setting pic.

Affinity Photo version 1.7.2 release, issue reproduces both on macOS and iPadOS

 

Test.afdesign

Test.tiff

issue.png

stroke setting.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.