Jump to content

Recommended Posts

Hi,

I'm a new user of Affinity Designer and already a big fan. While I personally have not detected a massive amount of new stuff in the recent update, I'm sure many users will welcome the additions. One thing I would like to see in future versions is some work on click proximity. Sometimes it seems like Affinity Designer will select any object in my design that has the remotest association with where I'm clicking, except the object I'm clicking directly on. Before anyone asks, no, I'm not trying to select a locked item. Going to Outline view is the only thing that helps sometimes and even then not always. Am I missing something?

N

Share this post


Link to post
Share on other sites
6 hours ago, Neil M said:

Sometimes it seems like Affinity Designer will select any object in my design that has the remotest association with where I'm clicking,

How about a demonstration?


Affinity Store: Designer 1.7.2.471, Photo 1.7.2.471, Publisher 1.7.2.471.
Windows 10 Pro, Version 1903, Build 18362.295.
Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.

Share this post


Link to post
Share on other sites

Hi Pšenda,

Thanks, I'll do that. It is intermittent. Next time I hit a stubborn one I'll record it. I overlay identical shapes sometimes and that's when it occurs. I though I might not be 'punching' thru correctly, but the I use the alt key and seems to punch through to overlays on simple objects. N

Share this post


Link to post
Share on other sites

Hi Pšenda,

Here is a movie of the click proximity issue. Here is a QuickTime .mov of the problem. I'm drawing a woman's hair, very simply. You'll see I'm clicking on a 'ringlet', the smallest object, that is behind the larger mass of hair on the right, but in front of a placed scan of a pencil sketch. So in reality the portion I'm clicking isn't 'behind' anything. The ringlet object isn't locked and I'm clicking with and without the alt key as it isn't actually overlayed by anything. Click, click, click – even on the outer vector rather than its fill  – no response. Most of the time when this happens I have to go to Outline view to get hold of it, as shown. Happens a lot. Maybe it's the scan behind that causes it. I don't know, but it adds up to half an hour to my day, or longer depending how layered the illustration is. Hope the attached works. N

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×