Jump to content
Ivan_M

Weird selection problem in Affinity Designer

Recommended Posts

Hello. I encounter some weird problem with Move Tool in Affinity Designer 1.7.1.404. Here's the steps before the problem appears: I duplicated and stretched one of these small red vertical rectangle(see attached pictures), then colored it green. After these actions it turns out that I can't select any other objects near this green rectangle by clicking on them - it select green rectangle only. Although I can select them by clicking and draging Move Tool from unaffected area.
It affected only area on the sides of the rectangle(dimension I have modified), not the top or bottom. On the second picture I hatched exact area there's effect appears - clikc on anything inside with Move Tool results only with selecting green rectangle. It runs from left side of working area to the vertical red rectangle on the right.
If I place another object on the layer above, selection works properly, but anything below is affected. If I stretch green rectangle in vertical dimension, affected area shrinks, but not disappearing. Closing and re-opening the document doesn't help.
As a wild guess, I think the program miscalculated my actions and  disproportionately increase the active area of new object.
All objects on separated layers, no groups. Problem appears not the first time and have a random character. Unfortunately, I didn't remember on what version it started.
Running on Win 10 x64.
How can I fix it?

Thanx.

selection problem 1.jpg

selection problem 2.jpg

Share this post


Link to post
Share on other sites
On 7/17/2019 at 5:40 PM, Sean P said:

Hi Ivan_M,
Welcome to the Affinity Forums! 
Do you have a copy of the document you could attach prior to it going wrong? If not could you attach the one shown in your screenshot please?

Hello, thanx!

I have the original document, but it's heavily modified now and I already deleted troubled objects, but I managed to recreate the problem again. I select object in group by a Ctrl modifier, Ctrl+C, deselect, Ctrl+V, then relocate, stretch it in one dimension(in my current case it's vertical) and effect appears again. One additional moment - the size of select-sensitive area is vary due the zoom scale, I marked the active area on 100% zoom.

СТОЛ_troubleshoot.afdesign

СТОЛ_troubleshoot.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.