Jump to content
You must now use your email address to sign in [click for more info] ×

Batch Process Creates Very Large Files Ver

Recommended Posts

This is a follow-up to the previous bug report (with attachments) titled "Batch Process Fails with version" submitted on 7 June and updated that the same problem occurs under version

Today, I tried to run a batch process against 21 files that ran one macro which simply created a copy of the background layer and then renamed the new layer.  Again, as with the two macro problem, it processed two files and then quit without an error. It was at that time that I discovered another error in that the .afphoto file created by the batch process is more than twice as large as the file that I created by dragging the same .tiff file processed by the batch process into Affinity Photo, running the macro to create a new layer and rename it, and then manually saved the file.  The file size of the .afphoto file created by the batch process was 359mb  the size of the afphoto file created by manually taking these steps was 159mb.  There is something wrong in the batch process. 

If you need a copy of the macro I use or the files that were created I can upload them. Further, I would say that I have been running these macros for a long time under previous versions without any problem. 

Thank you.

Link to comment
Share on other sites

  • 4 weeks later...
3 hours ago, GabrielM said:

Can you please attach the macro in question and a couple of source files?



@GabrielM  no problem with the delay. I realize you are all very busy.

Here are the two macros that I tried to run in a batch process that I mentioned in my "Batch Process Fails with version" submitted on 7 June.  For the problem stated in my "Batch Process Creates Very Large Files Ver"  the macro I was running was just the macro "Create Layer for Color Efex Pro 4".  Also, inclosed  are rebuilds of the two 16-bit .tif files that I referred to in the report.  The file ending in "2705_DxO.tif" is the file that when it was run in the batch process using both macros had a file size of 450mb and when I opened just the .tif file in Affinity Photo and ran the two macros only the size was 173mb.  I have both of those resulting files but to try to upload them here won't work.  I hope this information and the uploads are of help in the troubleshooting.

Thank you very much.


Marvin "Butch" Reinhart

Create Cleanup Layer.afmacro

Create Layer for Color Efex Pro 4 -.afmacro



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.