Jump to content
Sign in to follow this  
Mr. K

One Anchor Hyperlink Does Not Work In Exported PDF

Recommended Posts

One of my hyperlinks to an anchor works in my project file, but does not work in my exported PDF. I've tested a bunch of different things to try and solve it, but still no luck. Do you have any suggestions? I will try to post a sample file tomorrow with this "bad" link.

Share this post


Link to post
Share on other sites

I have had trouble with "duplicated" links by which I mean the name is the same for several or all of them, check the Hyperlinks Studio for a list of all the names.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.8.0.502

Share this post


Link to post
Share on other sites
6 hours ago, Old Bruce said:

I have had trouble with "duplicated" links by which I mean the name is the same for several or all of them, check the Hyperlinks Studio for a list of all the names.

It is not duplicated in the Hyperlinks Studio list of all the names. The link works in AFPub to show source and show target, but it does not work when exported.

Share this post


Link to post
Share on other sites

I stripped my file down to just the hyperlink text and the anchor. I attached the AFPub file here and I attached the exported PDF. I can't figure out why it works in the AFPub file but not the PDF.

Test.afpub

Test.pdf

Share this post


Link to post
Share on other sites
1 hour ago, Mr. K said:

I can't figure out why it works in the AFPub file but not the PDF.

I can't either. Having said that I did some work and think the bug you have found is due to the fact that the anchor was at the end of the line, when I replaced it into some where in a word all worked well in the pdf. Further investigation suggests that the Hyperlink was the entire paragraph and not just the three words "Melamine Cut Diagram". Changing the hyperlink to that made it work with Page or Anchor. 

When I say 'work' I mean in the PDF. As you reported it works in the Affinity Publisher document quite well.

Summery, maybe we can't put links or anchors after selecting all of a paragraph even if it is only one line without a return. I think it is the end 'Special Character' causing the problem.

Test.jpeg.22e4bbc5645ec8cef372ce1194e31976.jpeg

you can see how the anchor overlaps the 'end' character.

I hope I have been clear, still working on morning cup of coffee.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.8.0.502

Share this post


Link to post
Share on other sites

There is some sort of bug here, but I'm not sure what it is. Best for Affinity to look at the files. Can you please do so Affinity folks?

Share this post


Link to post
Share on other sites

I think the bug workaround is that we have to be very careful selecting text for Links and Anchors. What I do is make sure the Hyperlink Text is selected word by word so as to not include any special characters like the end of story (or what ever that thing is named, my dictionary is packed away), and I make sure the Anchor is placed within a word.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.8.0.502

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.