Jump to content

Batch processing not working


Recommended Posts

I'm doing a batch processing of images, using a four-step macro, and nothing is happening. 

The first four, from a list of 28 images are just hung up, the wheels spinning.

When I tried with a batch of just two images they were done immediately as far I can tell.

This works for three images too.

If I do four - it does nothing at all. It does not show anything as processing - though if I try to quit Photo it stops me, saying that there is a job processing.

I've also tried batching seven images, and the first four are just stuck - as in the first list of 28.

Is there something else I need to know to get this working?

I have over 200 images to process the same way.

I have a fairly recent iMac, with 16GB of RAM, and it never slows down normally.

So what could be going wrong here?

I've followed the Affinity video, going through several times. 

The only difference is that I am outputting as PNG.

 

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Same problem on my iMac 2017 since I upgraded to Mojave last week. On High Sierra, everything went fine, so I suspect that the upgrade broke something.

Unchecking Parallel Processing fixes the Problem, the Βeta does not. The Βeta worked fine though as long as I did not run my imported macro on the files (but actually just converted them). I'm looking forward to any updates; if you change something in the Βeta that might help here, please let us know in this thread!

BTW: Why is still the only possibility to stop a batch to force quit the app? Please consider adding a stop/abort button to the batch pane. Or did I miss something?

Link to comment
Share on other sites

Just to let you know: This seems to be fixed in the latest beta. I just ran some batches in Affinity Photo 1.7.0.135 and it runs perfectly (it did fail before the update download was completed), also with my macros imported from Affinity 1.6.7 and parallel processing enabled (and of course the new width/height expressions B| ).

Link to comment
Share on other sites

  • 1 year later...

Hey there,

Here's a weird one...

I'm on Mac Os Mojave, using Affinity Photo 1.8.3.

I have 165 png files (256x256 px) to process. The result is it saves the 1st file, but not the other ones. They are named like this:

cubase.png

cubase1.png

cubase2.png

... ...

cubase164.png 

I've first created a macro, that I've applied in the batch job window, "save into" another folder than the source, and I've checked "Save as PNG", unchecked "Save as AFPhoto". Parallel processing is also checked.

When I hit ok, only cubase.png is saved.

However, when I've started over, and didn't include "cubase.png", and just added cubase1.png to cubase164.png, after having repeated the steps described above, none of the files have been saved.

I wanted to check if it was related to the way the files are named eventually, but no. I've copied a few files from the serie, renamed them as follow:

cubase.png

cubase_one.png

cubase_two.png

.... etc...

Same result as the 1st try; it only processed and saved "cubase.png", none of the others.

 

I've started thinking there was a problem with these files. So I've tried to batch process them with another software. I've used a little app called PhotoResize. I've just resized them to 255x255, and hit "resize all". It worked! 

Then I went back to Affinity Photo, and tried again the batch job but using these new files. And then it worked. 

So, why Affinity Photo struggled processing these files, as a simple tool managed to do a process and save them all? 

I'm happy to send you these files so you can check what blocked AP to process them if you guys want.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.