Jump to content
inspiredmac

Photo and Designer have stopped opening

Recommended Posts

Affinity Designer and Photo have stopped opening and just bounce in the dock. If I download fresh copies of these programs and re-install them, choosing "Replace" on the install, will I lose all my filters and extras I've added? Or will the installer leave them in place?

Share this post


Link to post
Share on other sites

Hi inspiredmac,

I've just quickly tested this and used the Replace option and all my brushes, macros ect were still present in Photo.  However i'd still recommend following the steps on this video: https://vimeo.com/189596577 to backup everything as it's possible something could go wrong with the replace option and it would be better to have a separate backup of these just on the off chance something doesn't go to plan :) 

 

Share this post


Link to post
Share on other sites

SOLVED...

Before doing anything drastic, I decided to use the most powerful tool in problem solving — patience. I decided to see if, when, or ever the programs might suddenly open up. Well, it took a painfully long 2 minutes of watching the bouncing beach ball before Design and Photo finally opened. I have no idea why the programs are so reluctant to open, but they're obviously working in their own lethargic way. 

Share this post


Link to post
Share on other sites

Glad to hear they are opening :) 

Have you recently installed a lot of fonts?  As that a large number of fonts can cause Affinity to slow down. 

Would also be worth checking out the beta of Photo from here to see if that starts any quicker. Designer beta is here

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×