Jump to content

Superscript minus sign etal

Recommended Posts



I was wishing to superscript the -1 after ms-1 ( metres per second). I used the superscript icon within Character dialogue window. Whilst the 1 was superscripted, the minus sign was not. Upon further investigation, I found the same problem with plus sign. In addition, when two letters are selected neither of the will be superscripted. Further, I found similar problems with subscripting.

Test data: ms-1, ms+1, ms ?1, msaa.

The number characters are superscripted, letter characters are not.

This is reversed for subscript.

Arial was the font used.


This works as it should for both super and subscript in Affinity Designer and Photo.  


Share this post

Link to post
Share on other sites

Hi @Eileen,

How do you superscript?

Using the Typography options, you will only get the superscript if the font has got superscript characters. If not, it will not superscript them. 

Using the Position and Transform option, it will "fake" superscript them ( basically shrinking and moving their position ) regardless of the actual built-in superscript characters. 



Share this post

Link to post
Share on other sites


To make it clear: the dropdown marked '1' is for synthesized superscript and subscript; glyphs become smaller and are placed further up or down. The buttons marked '2' are for OpenType subscript and superscript. These only work when the font has these glyphs AND the corresponding font features.

Some fonts have these OpenType variants, but very few have variants for every letter, digit and mark. I actually have a font (Calluna) that offers OpenType superscripts but no subscripts. So I use the synthetic versions to keep them visually the same.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now