Jump to content

Recommended Posts

I just downloaded Publisher and am testing it on my late 2015 5K iMac (top end model with all the BTO bells and whistles).  When I click any of the blue tools (Rectangle, Ellipse, Rounded Rectangle, or Triangle) and then proceed to click and draw to sketch the object on the page, the gray fill of the object being draw lags behind my arrow cursor while it is being drawn.  For example, as I draw out to the right to expand its size, there's a white gap between the gray fill and the object edges at right.  And as I draw left and inward to shrink its size, the gray fill overflows the right edges of the object.

If you sketch the object very, very slowly, there are no issues with the gray fill of your object being drawn.  But if you sketch your object quickly (which is normal speed for me), you will see the problem with the fill very clearly.

Is this by design or a bug?

Not a big issue perhaps, but I mention it since the app is still in Beta.

Share this post


Link to post
Share on other sites

Is it really noticeable? We have had some lag issues with tablets are you using a table also ?


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

It's very noticeable.  If it wasn't, I would never have mentioned it.

No need to just take my word for it.  I created a screencast for you here (unlisted on YouTube):

 

 

Share this post


Link to post
Share on other sites

I just downloaded 1.7.0.145 and tested.  No improvement to the lag issue.  It happens on most tools, including the Artistic Text Tool .  Select that tool, then click and drag on your page.  You see a letter A being drawn with a blue outline and black fill.  The fill lags behind the blue outline as you drag to make it bigger and smaller.

I'm not suggesting this is a showstopper bug, but it looks very tacky and tarnishes the feel of your otherwise excellent app.  If you cannot fix this, then I suggest you add a preference setting to turn off object fill or content display (i.e., "draw outline only"), which is what InDesign does.  I'm not saying InDesign is better.  I am just saying that the lag may bother some people so you should try to fix it and if you can't then allow us to disable the root cause of the problem (realtime display of the fill/content).

Thanks.

Share this post


Link to post
Share on other sites

@JDW

You're Rendering speed my be set to Slowest (High Quality) in Preferences. See what the behavior is in Fastest. (PS. Fastest won't lower your quality if your machine is beefy)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×