Jump to content

Recommended Posts

Using Affinity desktop in Mac.  I have a jpeg which should not require rasterizing but I even tried that.  I duplicate the layer, make a selection with the free hand tool and press the DELETE key.  It deselects it.

 

If instead I make a selection with the rectangular or the elliptical tool and press DEL, it works.  Pixels inside selection are removed.

 

Is this normal behavior? I tried with a different photo and also restarted my laptop, but same behavior.   Of course, I can  remove the pixels by using Refine and Mask, but I would've thought that the Delete key would work to delete pixels inside any selection, regardless of how one makes it.

Share this post


Link to post
Share on other sites

Hi Silvia - exactly the same thing happens with me.

 

But try it while displaying the History panel. When you press Del, the history skips back to the previous step rather than deleting the selection. To get round it, you can press Fn-Delete instead.

 

This is very inconsistent programming - as you say, deleting a selection created with the rectangular marquee tool works as you would expect.


Affinity Photo 1.6.7, Affinity Designer 1.6.1

Various betas

macOS 10.14

MacBook Air

Share this post


Link to post
Share on other sites

Thanks, guys.   I did notice that issue with going back one step in the history panel instead.  I'll try the Fn+Delete keys to see if it works in my Mac.  I was feeling frustrated seeing it works with other tools but not the freehand tool.  It thought it was me doing something wrong.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×