Jump to content

Recommended Posts

Hi everyone,

 

This may seem like a silly question, but I'm having issues exporting an image after editing it. Every time I attempt to save and then export the image, it saves on my desktop as the original unedited image. Here's what I'm doing:

 

After uploading the image to Affinity Persona, I use the selection brush tool to select the desired part of the image that I want to keep, I then use the toggle quick mask tool to add a white background to the image. I then save and export the image to .PNG or .JPEG and both files still save as the original, unedited image instead of the image I edited with the white background. Am I doing something wrong? 

 

Thanks very much in advance for your help!

Share this post


Link to post
Share on other sites

File > save as & File > save are used for .afphot format

 

File > export is used for .jpg, .png etc  formats


Affinity Photo  1.7.3.481   - Beta 1.8.0.486

Windows 10 Home  1909 (build 18363.476) - 64 bit processor - AMD A4-5000 APU with Radeon HD Graphics  1.50GHz - RAM 8,00 GB
Calibrated Monitor (Datacolor Spyder5 Pro)

 

Share this post


Link to post
Share on other sites

After uploading the image to Affinity Persona, I use the selection brush tool to select the desired part of the image that I want to keep, I then use the toggle quick mask tool to add a white background to the image.

I am not sure what you mean by this. The quick mask feature is just a way to create a mask. You still have to do something with the mask for it to have any effect. Step by step, what did you do?


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites

I am not sure what you mean by this. The quick mask feature is just a way to create a mask. You still have to do something with the mask for it to have any effect. Step by step, what did you do?

Ok, perhaps that is the problem. Step by step, here's what I'm doing: select desired part of image with selection brush tool > add quick toggle mask to background in white > save/save as > export to .JPEG/.PNG

 

How can I add a white background to the image so that it stays permanently? Thank you!

Share this post


Link to post
Share on other sites
cdel1234,

 

I suppose you have only one layer in the layer panel ?

 

If so, than ...

 

Add a new pixel layer

Fill this layer with white

Drag it to the bottom

 

File > export      (as JPG or PNG)

Affinity Photo  1.7.3.481   - Beta 1.8.0.486

Windows 10 Home  1909 (build 18363.476) - 64 bit processor - AMD A4-5000 APU with Radeon HD Graphics  1.50GHz - RAM 8,00 GB
Calibrated Monitor (Datacolor Spyder5 Pro)

 

Share this post


Link to post
Share on other sites

 

cdel1234,
 
I suppose you have only one layer in the layer panel ?
 
If so, than ...
 
Add a new pixel layer
Fill this layer with white
Drag it to the bottom
 
File > export      (as JPG or PNG)

 

Thank you so much! That's what I was missing. I really appreciate the help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.