Jump to content
You must now use your email address to sign in [click for more info] ×

Patch Tool doesn't work (was: Andy Bennett)


Recommended Posts

Welcome to the forums, @Andy Bennett, @Cosmopolish, @Phil Jackson

Each of you need to provide more information so someone can provide meaningful help.

  • OS, Mac or Windows, and versions
  • Using a designated video card? IF so what (Nvidia, Intel...)?
  • Do you have Hardware Acceleration, OpenCL active? If so, have you tried to deactivate it? (Preferences>Performance)

Without being able to look over your shoulder, no one can see just how the patch tool is not working as you expect it to. So either provide a detailed description of what your doing, what it's doing or not doing, or upload screenshots or a short video clip showing this behavior.

Thank you. :)

 

Affinity Photo 2.3..; Affinity Designer 2.3..; Affinity Publisher 2.3..; Affinity2 Beta versions. Affinity Photo,Designer 1.10.6.1605 Win10 Home Version:21H2, Build: 19044.1766: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz, 3301 Mhz, 6 Core(s), 12 Logical Processor(s);32GB Ram, Nvidia GTX 3070, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Link to comment
Share on other sites

Hi,

  •  Windows 10
  • Nvidia GeForce GTX 1050
  • Hardware acceleration was active on default and the patch tool didn't work. When disabled, the patch tool works.

I had 3 different issues with the patch tool:

1. When selecting the area and clicking away to confirm I get lines across the selection and some strange noise in the histogram.

2. When selecting the area and clicking away to confirm I get a black patch in place of the selection.

3. The patch tool works more like a hard stamp tool.

I hope it's visible on the screens attached.

 

1+2.jpg

3+4.jpg

5+6.jpg

Link to comment
Share on other sites

  • Staff

@Andy Bennett

Welcome to the Serif Affinity forums :) 

To all in this thread:

This issue in 1.9.0 when hardware acceleration is enabled has been addressed in the latest beta released yesterday

You can install the beta in parallel with the release version if you want to try this fix for us.

This problem will therefore be addressed in the 1.9.1 update that will follow soon. 

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.