Jump to content

Setup Failed - Cannot Update to Affinity Photo 1.9


Recommended Posts

Hello,

Normally I run in to setup failed when trying to update Affinity Photo, that's nothing out of the blue. If I restart and try again that works.

But I simply can't get this latest 1.9 update to install no matter what I do. About halfway through the installation I get "setup failed."  I have restarted (full shutdown full startup) and tried running it as administrator. I've redownloaded the update thinking, potentially, it was corrupted. Nothing worked.

Perhaps its because I only have 2.04 gb free on my SSD? If that's the reason, I really wish the error message was not that vague. But I seem to remember being able to update with that little space left in the past. 

Unfortunately it is impossible for me to free up any space. I have several programs that I absolutely need and, yet, they simply don't have the option to install on another drive (*cough* this included Affinity Photo, potential feature request here *cough*). I really hope 2gb is enough to install an update. 

Ryzen 5 1600, 24GB RAM, GTX 970 4gb, 128gb SSD for main drive (+500gb nvme +  300gb hdd + 1tb hdd  as well). 

Link to comment
Share on other sites

7 hours ago, HuniSenpai said:

I have several programs that I absolutely need and, yet, they simply don't have the option to install on another drive (*cough* this included Affinity Photo, potential feature request here *cough*).

When you first install Affinity Photo, at least if you purchased from Serif, you have the option of where to install. After that, updates go to the same drive you chose initially.

(Unfortunately, however, some items still go on C unless you have played some games configuring Windows to move them. The main program files can be directed to another drive, but some go into the Windows ProgramData folder on C, and a bunch go into the user's AppData folder (also placed by Windows on C).

But that doesn't help solve your problem. For that, take a look at the FAQ below, and start with the one for Setup Failed. The SetupUI.log file probably has more information to explain the issue.

 

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.4.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.