Jump to content
Ull

Transparent color reveal white shapes

Recommended Posts

Hello,

I encountered a strange behaviour in affinity designer :

     1. On a blank canvas I create a blank square

image.png.bbf4ee8ee765d5090551a9e356bc3372.png

     2. Then, I create another square with a opacity of 50% for example.

image.png.4e4e921717b32ff3ec1ddf2b672e2a47.png

     3. The shape of the white square is now visible :

bug.gif.f82cc3f20fb02e4bd5a00be23ebe218c.gif

 

If we export to SVG or PNG, we don't see the artefact.

 

image.png

Share this post


Link to post
Share on other sites

Hi @Ull Welcome to the Affinity forums. I've just recreated this and it looks like it is to do with display settings.

What do you see selected for Display if you go to Edit from the Menu > Preferences > Performance............?

Share this post


Link to post
Share on other sites

How about if you go to MenuDocument > Convert Format / ICC Profile > Under Profile.......... What is selected? Can you also tell me what screen you are using please?

Share this post


Link to post
Share on other sites
11 minutes ago, SPaceBar said:

How about if you go to MenuDocument > Convert Format / ICC Profile > Under Profile.......... What is selected? Can you also tell me what screen you are using please?

image.png.0c52b8386e50639786a72f355582e5a3.png

 

As listed my screen is a S27R75xQE (Samsung Space Monitor). If I select it, it resolve the issue !

image.png.95263a58d53eff1cbf2d7a89e588d6f1.png

 

Thanks !
 

Was this a bug or really just a bad setup from my part ? I couldn't find any help on this issue on the internet/forum, so that's why posted this !

 

Share this post


Link to post
Share on other sites

Hey @Ull we did manage to recreate it here by changing those settings but I will hopefully be able to answer your question tomorrow after a bit more research.

 

Share this post


Link to post
Share on other sites

Thanks @prophet I was able to work around this on my work iMac which is the same as yours by doing this:

  • On the Menu bar > Click Affinity Designer > Preferences > Display: Does it say OpenGL? If so choose Metal > It asks you to restart the software.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.