Jump to content

Problem installing Photo Beta after update failed

Recommended Posts

I have a problem with affinity photo customer beta on windows.

On monday when the update process was on is way, my pc was shut down by a general power off occurred even in the streets.

After that i can't install it anymore... Always setup failed, the uninstall process too, then i've tried to remove manually the installation folder and i've used ccleaner to remove the registry entries, but even that way it doesn't work... it still appear on the "installed applications" but i can't remove it because it give me some binaries error. I've tried installing the version that was there before, but setup failed too...

Any ideas?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.