Jump to content

StephanP

Members
  • Content Count

    26
  • Joined

  • Last visited

  1. Ok, I did some further testing and it's in the character style language alright. Not in the spelling checking. Apologies for the confusion. So, this seems to boil down to a Change request: Could the Dutch character style be changed such that it converts quotes into English typographic quotes, because that's how they're supposed to be.
  2. No, the Dutch language spelling checking and Dutch character style settings are not related to this issue. Before I installed the Dutch dictionaries, all my preferences were default English and I got the same German style typographic quotes. I suspect it has to do with AP on Dutch language Windows system.
  3. Bump. I'd be interested to learn if this some odd behaviour of Affinity Publisher when it's installed on a Dutch Windows 10 system, or if it's something that can be cured in a simple manner.
  4. Yep, once Preferences - Spelling checking is set to Dutch language, Dutch is also the set language in the Character panel. "It's all Dutch to me" I suspect a bug and opened a new query, as this thread initially started about search and replace in existing text.
  5. A sample file to go with this Typographic quotes example.afpub
  6. I can't seem to get the right typographic quotes conversion. In Preferences - Auto-Correct, I've enabled the options "Change straight quotes into typographic quotes" as well as "Support language depend single quotes ..." I've set spelling checking to Dutch, which I installed manually and is functional. When I type straight 'single quotes' or "double quotes" I expect these to be converted into typographic ‘single quotes’ or “double quotes”, respectfully. Yet, somehow I get German style typographic ‚single quotes’ and „double quotes” with base opening quotes. I've made a small experiment extending the nl_NL.aff with two mappings, but that didn't work either. It seems to me that the typographic quotes conversion is hard-coded to produce German style base opening quotes. Is this a bug? Relevant specs: Windows 10 (1909) (Dutch language) AP 1.8.3.641
  7. I tried adding the following lines to the nl_NL.aff MAP ‘( ') MAP “( ") But this didn't do the trick either
  8. I've got the Dutch spelling checking in place now according to FAQ, but the typographic quotes are stil wrong. If this is something that could be fixed in the editable .aff file, then I'd be happy to learn. Edit: Note that I in fact completely lost the typographic quotes. Edit2: Correction. The typographic quotes are there alright. it's the Arial font that doesn't have 'sexy' quotes.
  9. BTW, I did a small experiment where I added an autocorrect to the English language: replace „ with “ But this did not change a thing. Apparently the autocorrect into typographic quotes is executed after the autocorrect from the list.
  10. There is no Dutch language spelling checking, so I left it at default English. Is there a way to create one's own spelling checking configuration? I could start with setting the desired typographic quotation marks and add common typo's as I go.
  11. @walt.farrell When I type: The man said: "Watch out!", autocorrect inserts lower opening apostrophes and upper closing apostrophes. In Dutch language opening and closing apostrophes are both of type upper. Is there a way to setup autocorrect such that it inserts user defined opening and closing quotes?
  12. I take that back. I decided to regenerate the TOC as well as the PDF and the hyperlinks did materialise in all the PDF-viewers I've got. Possibly, something had gone bad while fiddling with the TOC I generated earlier.
  13. I'm using 1.8.3 and I have generated a nice TOC, which shows the right page numbers. But when I export the document to PDF (digital, high quality) with the option include hyperlinks enabled, the resulting PDF does not show TOC hyperlinks in Acrobat Reader DC, PDF-XChange Editor or the browsers Edge or Vivaldi. Did I miss some other option or should I add the hyperlinks manually?
  14. New downloads NOT to the NAS, but the local drive solved the issue. Both installations went along just fine.
  15. extracting the .msi resulted in checksum errors. Need to download again.
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.