Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Editing a APH composition as a PSD with new Beta update. Bugs.


Recommended Posts

Hi friends.

I have just updated the my APH beta. Well..it seems that this is being done almost every week now.

Then, I have decided to see how my composition done in Affinity Photo would result  in Photoshop.

It  has received admittance as a multilayered composition, but I had to change the place of some of them, and looked for the blending modes again for in some layers they had lost the original one. Somehow the image , properly re-organized in its layers, was more or less the same as in Affinity. Hope that if I wish to do some extra re-touching in the same one I will not have problems.

 

But then, as I returned to my Affinity Photo image, I tried to add something. Let´s say, an extra square form that was to appear behind some object as a "particular" shadow effect...and all the think simply was corrupted. It broke the image in white rectangular shapes and could not do it at all. Besides I became aware that some layers had lost their effects little icons, and though the effect, (bevel) was still in the image I could not longer edited to change it or delete it.....Bug!!!!!!

 

For your acknowledgement....I had already done two more compositions, and I guess had been done with the previous Betas. They have not been admitted as separate layers by the Photoshop edition....for the system simple has told me that "something strange and alien was going on in the layers". I suppose that the last updated, has fixed that.

 

Meanwhile I am a it puzzled by the problems that has come out in my composition.

May be you could inform me about it a bit more...wether someone has reported something likely..or well..what is happening.

 

Thank you so much

Rosa

 

 

Link to comment
Share on other sites

  • Moderators

Hi Rosa,

 

I've just tried this with a multi layered PSD file i created in Affinity Photo and it opened up correctly in Photoshop with all layer blends correct and layers in the right place.  The only issue i had was with the bevel i applied in Affinity Photo, it would appear by saving it in Photoshop stopped me from editing it again in Affinity Photo.

 

Without seeing your file it's hard to say what would of caused these issues with layers and blend modes.  Any chance you could attach it to a reply here or email it over to support@seriflabs.com  If you could include a link to this post that would be great.  Once we have finished looking at the file, we will delete it from our system.

Link to comment
Share on other sites

Thank you so much

I would not mind linking the file but the problem is that I do not know how to do it. What kind of file should I link. ? and how would the link be donein order you could get all the actions in the image? I have seen that some people do screen their works in here,mbut I do not know how to do it. Could you help me with thqt, please?

Thank you in advqnce for your attention and help.

I will keep on awaiting for your news.

Rossa

Link to comment
Share on other sites

  • Moderators

Hi Rosa,

 

I'd be happy to show you how to attach a file.  When replying you should see a button that says 'More reply options'  It's right next to the Post button, click 'More reply options' and you will now get a slightly bigger window to type in, at the bottom of this window you have an option to attach files.  Just click the button 'Choose Files...' and then browse to your PSD file.  

 

If it's larger than 20MB then you will need to send it via a service like http://www.filedropper.comand once uploaded just copy the link you are given from Filedropper into a reply and i'll be able to download it.

 

When people record their screen, most use Quicktime, you should find its already on your Mac and on the File menu you have an option to Record screen.  The steps to follow, can be found here: https://support.apple.com/kb/PH5882?locale=en_GB

 

Any problems getting the file to me, just let me know and i'll be happy to help :)

Link to comment
Share on other sites

Thank you so much.

This is what I have done.

I have exported my Affinity Photo composition as a psd file, in order to see if those problems that I had seen were still there. They are still there.

So I am sending you two files. One has been corrected into the right image the one I had created...and this is of course the named "mandgoreducide psd"...and the other is the one that has been exported directly from Affinity.

 

You can see there, the errors I have found and the way the things are showing.

I thank you very much for your help.

I may try the screen recorder, specially for you chek what the problems I do find now in my Affinity PHoto composition after having exported it to psa file.mangoreducido.psd

Rosa

(should I record the screen of the Affinity PHhoto composition?)mangopruebaaffinity.psd

Link to comment
Share on other sites

Hi.

I have had not problems in recording the screen with Quick Time Player, but I am not been able to post it in here because it is huge in size. Is there any way to low the weight of the screening? I could not see it in Quick Time anyway. Well...I may try the loading service  but just in case you won´t be able to see what is happening.

Thank you so much. You cannot imagine how much I have learnt with your help, today.

Rosa

Link to comment
Share on other sites

  • Moderators

Hi Rosa, 

 

Glad i could help and that you have learnt some new skills.  I can't even tell you how much i've learnt since i started supporting the Affinity range, but that's the great thing about this line of work, always learning something new with everyday.

 

Don't worry about the screen recording for now. I tend to only record part of my screen to keep the file size down, recording at full screen results in a huge file but not to worry, the fact i've got both the PSD files i should be able to see what's happening :)

 

Currently at home, so will look at these 1st thing tomorrow morning.

 

On another note, i've just checked in for my flight to Spain a week on Saturday, flying into Alicante to visit my parents for 2 weeks down in Mazarron.  They retired and moved from the UK to Mazarron about 4 years ago, so i get over as much as i can.  Really looking forward to the great seafood and relaxing on the beach :) Such a beautiful country and i hope to see more of it.

Link to comment
Share on other sites

Thank  you so, so much.

I hope you will have the best of your time at Mazarrón. . A bit hot is there I guess....but, well...soaked into the Mediterranean Sea...nothing is really hot.

I will wait for your checking out!

Greetings..

Rosa

Link to comment
Share on other sites

  • Moderators

Hi Rosa,

 

Well this is very odd.  I can see the difference right away between both PSD files.  1 blend mode hadn't be carried across and then we have the loss of the blue colour along the top.

 

Could you attach the .afphoto file and i'll get it logged with the Dev team to take a look at.  

Link to comment
Share on other sites

Thanks a lot,

You mean a jpeg file exported out from the aph composition?

Will do it, Though if you wish I may wait until you get back from Spain, for tomorrow is already Saturday...Meanwhile I can work with more compositions and study the app beta with more detail It is well probable that a new update will come for the next week, as things are going now,..so it may be that nothing wrong will happen in the next ones. Each updating seems to have its own "soul"

 

Have a real good time and we will "see" after your vacations.

You have done a real greate job as a moderator, It has been very nice to have met you,

Rosa

Link to comment
Share on other sites

@rosa cobos: Thanks for reporting this issue, I am interested in seeing this solved too. He does not mean exporting a JPG file. To troubleshoot the issue in Affinity Photo they need the affinity document (not psd, not jpg, etc) so that they can do testing to see why these particular settings in your afphoto document aren't exporting properly to psd. So please try to attach the ".afphoto" document.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.