Jump to content
Janis

Designer Performance slower rendering with Nvidia GPU compared to Intel

Recommended Posts

Hello

The problem:
I have have had Affinity Designer for 1 year now i think, but had not used it for a while. Came back to 1.7.1 version and the program felt a bit slow. I did update to 1.7.2 and still have this issue,
With slow i mean, every time i used the view tool, the screen felt like, it was moving with a 0.1sec delay (huge smoothign effect) same goes for selection tool when selecting an area or simply moving objects, Bigger files around 50-60 MB are even worse sadly.

What i tried:
I tried looking into the performance settings and found the cause, which is the Nvidia GPU render option. I use laptop so i tried integrated card: Intel HD 630 and it started working pretty smooth, but has weird lag spikes from time to time. What may be the cause for the software to slower down on Nvidia GPU? 
First i thought i may have throttling issues, but i have undervolted my CPU and the laptop never reaches more than 42* temp. 

My laptop specs:
Dell XPS 15 9570
CPU: Intel i7 - 7850h
GPU: Nvidia GTX 1050 TI - Max Q edition
Ram: 32Gb

In short, the Intel Graphics work better which should not be like that and any help is appriciated :)

Edited by Janis

Share this post


Link to post
Share on other sites
5 hours ago, Lee D said:

Do you have the latest Nvidia graphics drivers installed?

Hello Lee, thanks for the reply, but sadly no, the latest Nvidia driver didn't fix it, still lhas that delay-ish feeeling when using view mode, the Intel HD graphics still feel snappier, any other solution? 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×