Jump to content
ibrator

Affinity Photo Crashes on opening .RAF files.

Recommended Posts

Posted (edited)

Hello, 

I just recently upgraded to a new pc build and Affinity Photo crashes on opening .RAF files from Fujifilm X-T3. Files were opening fine before on my previous machine.  

I'm using Win 10 Pro 64bit - Nitro+ RX580 8gb and Nvidia Quadro P1000. Ryzen 5 3600, Sabrent nvme, 16gb 3000Mhz, B450M Mortar, 550W psu. 

.Raf files on in Affinity Designer. 

I downloaded the latest copy of Affinity Photo and I've also tried the beta version. None of them worked. 

If you need crash report how do I get you one ? Do you require any other information ?

Regards, 

John,  

Edited by ibrator

Share this post


Link to post
Share on other sites

Hi ibrator and Welcome to the Forums,

Normally a crash when opening a file or starting a new document, is graphics card driver related and performing a clean install of them should resolve the issue.  When you run the setup for the drivers, click on the Custom option and it should offer you the choice of a clean install.

If that doesn't help, can you attach a RAW file or let me know the model of camera you are using.

Share this post


Link to post
Share on other sites

Hi Stokerg, 

I'm still having issues with my machine. Had a couple of bluescreens, sometime just a machine restart. I tried to reinstall my drivers countless of times and reinstalled affinity photo many times as well. I'm still having problems. 

Happens to any .RAF raw files which is the Fujifilm format for X-Trans sensors. I have attached a sample, but it happens to any .RAF for my X-T3 and X-T2 files. 

Here is one of the entries for Affinity photo not working this morning: 

Faulting application name: Photo.exe, version: 1.7.2.471, time stamp: 0x5d56672a
Faulting module name: ntdll.dll, version: 10.0.17134.799, time stamp: 0x7f828745
Exception code: 0xc0000374
Fault offset: 0x00000000000f479b
Faulting process ID: 0x7c0
Faulting application start time: 0x01d554c5ba1a8ffb
Faulting application path: C:\Program Files\Affinity\Photo\Photo.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report ID: d432e189-11e9-4f93-99d1-9bfe0af45caf
Faulting package full name: 
Faulting package-relative application ID: 
 

A bluescreen error on trying to open Affinity Photo later on in the day:

Problem Event Name:    BlueScreen
Code:    be
Parameter 1:    fffff8085de1dae0
Parameter 2:    9000000d9eba121
Parameter 3:    ffff95082944ba60
Parameter 4:    a
OS version:    10_0_17134
Service Pack:    0_0
Product:    256_1
OS Version:    10.0.17134.2.0.0.256.48
Locale ID:    2057
 

I've attached a copy of Windows 10 Reliability report highlighted potential problems. I've using Eset not as to Windows defender moments ago. 

Regards, 

John, 

DSCF4900.RAF

reliabilityreportWin10.PNG

Share this post


Link to post
Share on other sites

Think I found the issue. It's to do with overlocking, however I can't get advertised clock speed for my ram if I don't overclock them. Will need to play around. At least I think it's the rams. But I also reduced cpu clock as well. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×