Jump to content
Michael117

Table end of cell and end of table characters are mis aligned

Recommended Posts

AF Pub v1.7.0.283
Mac OS X 10.13.6

I'm trying to create a new table:

  1. Turn on Text>Show Special Characters
  2. Click the Table tool to insert a new table.
  3. Draw the Table on the page.
  4. The special characters for the cells of the table are not where they should be.  See the screen capture below.

As you can see there are no special characters in the first two rows and a row of special characters shows up under the table.  The Text Style box shows that there are two text styles applied to the table text: Text Box+REB-RuleEndOfBlock.  The RuleEndOfBlock style is used to put a ruled line at the end of the section as a visual queue that the reader is at the end of that part.  

Table Body + REB-RuleEndBlock + Align paragraph: Left; Align to baseline grid: On; Left indent: 1 in; Right indent: 0.1 in; First line indent: 1 in; Paragraph decorations: off

I detached the table paragraphs from the text styles, then reapplied the Table Body text style.  When I applied the Body text style to the text paragraph above the table, the table text style changes to become Table Body + Body. The text style now shows:

Table Body + Font size: 11.3 pt; Default tab stops: 0.944 in; TabStop: 0.944 in; TabStop: 1.889 in; TabStop: 2.833 in; TabStop: 3.777 in; TabStop: 4.722 in; TabStop: Right 5.666 in

The second image is what I see when I try to enter text in Row 1.  Also note that the column letter cells are not lining up with the body columns.

Even if I detach the text styles, the text is misaligned with the table. 

I attached the sample file that I'm working on.  

 

Table Special Characters.jpg

Table Text.jpg

IM Document Template.afpub

Share this post


Link to post
Share on other sites

Your Table Style has inherited the Align to Baseline grid. Turn that off in the style, or adjust the baseline grid.

24 minutes ago, Michael117 said:

The second image is what I see when I try to enter text in Row 1.  Also note that the column letter cells are not lining up with the body columns.

Even if I detach the text styles, the text is misaligned with the table. 

 


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.2 | Affinity Photo 1.7.2 | Affinity Publisher 1.7.2 | Affinity Designer Beta 1.7.2.2 | Affinity Photo Beta 1.7.2.151 | Affinity Publisher Beta 1.7.2.458

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×