Jump to content
thetasig

Master Field values disappear on moved pages

Recommended Posts

I have a Master with section and page number fields. Each document page has a background photo set to "Move to Back" with other objects in front of that. The section and page numbers are visible on those pages. When I move (drag and drop from the "Pages" list) a page from one place to another position in the document, both the original location and final location pages hide the Master Fields - they do not appear. The background photos are still set to "Move to Back" but the fields are hidden "behind". Remove the background photo and the fields are still on the page. Have to remove and replace the background photo and "Move to Back" to fix it. This has a randomness as some other actions can cause the hiding of the Master fields (just opening the working document, for example).

Share this post


Link to post
Share on other sites
2 minutes ago, thetasig said:

Each document page has a background photo set to "Move to Back"

I'm not aware of a setting like that. Can you describe where it is, or show a screenshot?


-- Walt

Windows 10 Home, version 1809, 16GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.243 Beta
Affinity Designer 1.6..5.123 and 1.7.0.243 Beta
Affinity Publisher 1.7.0.238 Beta

Share this post


Link to post
Share on other sites

Sure - it is via a right-click of the object, a context menu drops down and one of the choices is "Arrange" and it has several options. I use it to "layer" the objects along the "Z" dimension so that I can have a background photo and overlapping objects.

1670312978_ScreenShot2019-02-11at2_06_10PM.png.8a4f6b8e56bf50e7a58a8834a0e3d705.png

Share this post


Link to post
Share on other sites

Thanks, @thetasig. I'm aware of that.

Note that that is not a setting, it is an action. It does not say "keep this at the back" but rather "move this to the back, right now".

You seem to think it will keep things at the back, but that's not correct.

However, even with that, I don't yet have an explanation for what you're reporting.


-- Walt

Windows 10 Home, version 1809, 16GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.243 Beta
Affinity Designer 1.6..5.123 and 1.7.0.243 Beta
Affinity Publisher 1.7.0.238 Beta

Share this post


Link to post
Share on other sites

And I see no reason why moving pages would change the layer order. For one of the pages that exhibits the problem, can you show us a screenshot of the page before moving it, including the Layer panel? And then a screenshot after moving the page that shows the problem, and also includes the Layer panel?

Can you attach a sample .afpub file that demonstrates the problem?


-- Walt

Windows 10 Home, version 1809, 16GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.243 Beta
Affinity Designer 1.6..5.123 and 1.7.0.243 Beta
Affinity Publisher 1.7.0.238 Beta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×