Jump to content
narrationsd

Missing Font Substitution issues

Recommended Posts

I've got a document Publish isn't treating very well this way. Pix attached, I hope in order.

  1. The text is placed from an rtf, which  _may_ misidentify the font in question Frutiger Neue LT Pro, Book face, improperlya
  2. On opening the afpub in Publish, it flashes an alert that there are missing fonts. And this alert soon disappears, either on a timeout or first touch of the trackpad, not sure. _Please_ do not disappear such information until closed; and please do give a button to go to the Document  Font Manager, which I discovered only by easter egging is apparently where you can deal with this.
  3. Now,  afpub-bad-font-presentation.png shows how this missing font looks in the font window. Yes, wrong name (should not have Book on the end of it, and Face should be Book instead of greyed.
  4. So, go to the Document Font Manager to try  to substitute it, and then the fun begins. Reference afpub-wrong-substitution.png
    1. I can find the actual font, Frutiger Neue LT Pro; ok but sometimes there are big delays (circa 10 second) before a font name will 'take' and show, after selection. Varies.
    2. I can _try_ to set a face. Once in a while, it will set, but not 75% of the time or so. Instead, the face selection shows for a few seconds and then reverts.
    3. Meanwhile, the text you see behind the dialog may or may not actually end up with the selected face. Usually not, whether or not the face name 'took'. In this case, Book Italic seems to be selected, but what Publisher decided at some point before stuck, which is Condensed Medium.
  5. So, now try to fix by changing the actual font applied to the text. This works, but given not all of the text was selected, we have the Document Font Manager showing both fixed and unfixed font listing...with the apparent same _wrong_ font name. It should not ever have 'Book' in the font name...see afpub-mixed-up-substitutions.png.
  6. Saving, closing, and reopening, I still get the fugitive 'Missing font' alert -- even though the font has  been substituted.  Maybe you think this is good, but what should really happen is that there is a Preflight ability, which I don't find -- and that is where font substitution warnings should appear, once they've been done. Quite possibly this is simply on your list moving forwards, would imagine your good imagination ;)
  7. I'm attaching how InDesign sees the same font: properly separating name and face. And also what Windows 10 latest thinks, which is actually proper though you can't easily discern it from this static shot, but can when you switch which face it is giving info for. See indesign-proper-font-choices.png and (Win10) frutiger-new-fontinfo.png

Ok, and so you know, I'm finding Publisher very neat already. More excellence in thought and designed abilities from you guys at Serif. Very much appreciated, yes.

Regards, Clive

p.s. yes, I'm also going after where that original wrongly-concatenated font name apparently came from, which is a Scrivener Windows beta. But would remind that you are seeming to do the same thing in your font substitution dialog,  point 5. Since you have it  properly separated in the Font window, it's probably just a formatting need for the substution dialog, so the font and face don't get entirely mixed, as they are now.

 

afpub-bad-font-presentation.png

afpub-wrong-substitution.png

afpub-mixed-up-substitution.png

indesign-proper-font-choices.png.954c13c9c67f13af38605d18b290dc14.png

frutiger-neue-fontinfo.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×