Jump to content
Thisismandatory

BUG: Windows keep being on the external window even after disconnection

Recommended Posts

Using two monitors and keeping some of the windows (resource monitor) on the secondary display, after disconnecting won't return to the main window.

Keep in mind I am using a laptop with external monitor. When external monitor is connected it acts as the main display. Closing the lid an putting the computer in clamshell mode results in the window not jumping on the only monitor used.

Share this post


Link to post
Share on other sites

Hi Thisismandatory,
Sorry the delay getting back to you. I'm having trouble reproducing this here. I've tried placing the Resource Manager on my laptop screen and the main app window on my external larger screen. After closing the laptop lid (clamshell mode) the Resource Manager switched to the external screen as expected. I've also tried this with three different panels (Character, Paragraph, Stroke) plus the Guides Manager and Resource Manager - all on my laptop screen with the main app window on the external display. Again closing the laptop lid switched all the 5 to the external display. I've also tried the opposite, turning off my external display with all those panels there (while keeping the laptop open) and again all switched to the laptop. In my case the external display is connected via DisplayPort (though a Thunderbolt 2 port on my laptop + adapter). Are you using other connection type? HDMI? Are you able to reproduce the issue consistently or was just a one-time event?

Share this post


Link to post
Share on other sites

Hey!

After this post, I haven't used it much this way, I needed 2 screens all the time. I have thought tried this again now. And after closing the lid, the resource manager is nowhere. I have to switch desktop (swipe left and right) to get the manager back on the screen.

Since, this might be setup oriented, let me give you the details.

I am using a MBP 2016, so the only ports I have are USB-C. I have the monitor connected through and USB-C to HDMI cable (no adapters). The external monitor is set as the main screen. APub is opened on the external monitor (main screen) in full screen mode. With this configuration, the issue can be consistently reproduced.

I have now tested another option, which is to have APub run in windowed mode and the issue is not to be seen. So this happens only if APub is opened in fullscreen mode.

I hope this is enough detail. If not, I can provide additional info. 

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.