Jump to content
Loquos

Designer not recognizing FontBase active fonts

Recommended Posts

I recently switch from RightFont to FontBase as my font managing app. With RightFont, Affinity always found and recognized fonts organized through RightFont, even if some of those fonts only existed in a folder in the Cloud. I have the exact same setup with FontBase, however, it not longer seems to find or recognize fonts. Unless that font is in a local folder - once I drag a copy from the cloud to my local folder, it loads just fine.

 

Has anyone else had this issue? I'm going to reach out to FontBase as well, but I thought I'd check and see if any Affinity people have been having issues with FontBase.

 

Thanks!

Share this post


Link to post
Share on other sites

I'm a Rightfont user and i've tested Fontbase, but on Windows and i think that the behaviour is the same on MacOS. When you activate a font in rightfont it will remain activated even if you close it, but fontbase deactivate it as soon as you close it... If fontbase keep fonts active after close it would be a really good alternative...

I have a folder on Google drive where i place my fonts and sync between my machines. I've droped it on fontbase and it's good to go if you keep it's windows open.

Share this post


Link to post
Share on other sites
3 minutes ago, dcarvalho84 said:

I'm a Rightfont user and i've tested Fontbase, but on Windows and i think that the behaviour is the same on MacOS. When you activate a font in rightfont it will remain activated even if you close it, but fontbase deactivate it as soon as you close it... If fontbase keep fonts active after close it would be a really good alternative...

I have a folder on Google drive where i place my fonts and sync between my machines. I've droped it on fontbase and it's good to go if you keep it's windows open.

 

I keep FontBase up and running in the background. That doesn't bother me. But it's running before I start Affinity, and I still get errors of not being able to find fonts. Which I never got before with RightFont, unless I forgot to activate a new font.

 

I am having the same issue with Adobe InDesign not finding font files, so I have submitted a ticket to FontBase, as I think it's their issue, and not Affinity's.

Share this post


Link to post
Share on other sites

On Mac i use Rightfont (which i think it has some problems now) and use Fontbase on Windows without problems.

Are you using High Sierra? Can i ask you how many fonts do you have active? Because i'm having some troubles with fonts too.

Share this post


Link to post
Share on other sites
3 hours ago, dcarvalho84 said:

On Mac i use Rightfont (which i think it has some problems now) and use Fontbase on Windows without problems.

Are you using High Sierra? Can i ask you how many fonts do you have active? Because i'm having some troubles with fonts too.

 

My desktop computer is not on High Sierra. I am running 10.12.6 on a mid-2010 model iMac.

 

Active fonts show "552" in the "All" Category, but those are technically about 80 different font families, plus standard system fonts. Same amount I had while using RightFont.

I am running High Sierra 10.13.2 on my laptop, which also uses FontBase. It has the same setup, same version of FontBase, but programs DO NOT complain about missing fonts. So it must definitely be a FontBase problem.

Share this post


Link to post
Share on other sites

OK! So I have the answer.

 

It was perhaps my own misunderstanding on how to set up FontBase so I would have the same fonts synced across different computers using DropBox when DropBox is synced to a SECONDARY drive.

 

Per FontBase customer support, I received the following:

Quote

 

The issue on your desktop seems to be in the FontBase root folder location. You mentioned it is located at /Volumes/Macintosh HD/Used/jackiewyant/Dropbox/FontBase and on laptop it's /Users/jax/Dropbox/FontBase.

We seem to have reports, that having FontBase on a different volume, other then the main, causes issues with the activation.

 

So you can try moving the root folder to a different location on your desktop and see if that helps. To keep it linked to Dropbox, you can turn on watched folders in the settings, then remove all the stuff from the root folder, and after that drag the folders from your Dropbox into the app.

 

 

However, I followed this set up and I'm STILL having problems on my desktop computer. My laptop still doesn't have any issues, though I made sure to also set up it the same way, so I'm consistent across machines.

 

I've reported back to them and I'm waiting for further info as to why things aren't working on my desktop computer, but are working on my laptop computer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×