Jump to content
Watcher

Affinity Photo (Windows) crashes on startup, where do I get assistance

Recommended Posts

I installed Affinity Photo. The software crashes on startup. The following are the contents of the Event 1001, Windows Error Reporting entry:

 

Fault bucket 478944926, type 30
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: Photo.exe
P2: 1.5.0.45
P3: 58480606
P4: Serif.Affinity
P5: 1.5.0.45
P6: 58480604
P7: 33
P8: 6c
P9: System.NullReferenceException
P10:

 

The error file, Report.wer, is available. I do not know how to view the contents.

 

Where do I get assistance to resolve the issue? Is it system configuration, missing item(s) from minimum requirements, or simply the need to reinstall?

 

 

Share this post


Link to post
Share on other sites

Hi Watcher,

 

Welcome to the forums.

 

Try resetting the app by holding down the CTRL key and opening the app, on the window that opens select Clear. If this fails to resolve the issue can you check the following folder %APPDATA%\Affinity\Photo\1.0\CrashReports to see if it contains any crash reports. To get here follow the steps below.

 

1, Windows key + R

2, Type %APPDATA% press Enter

3, Browse to Affinity > Photo > 1.0

 

Can you also confirm your system spec?

Share this post


Link to post
Share on other sites

Thank you.

 

I tried resetting the app by holding down the CTRL key and opening the app. The response was the same as previous. I checked for the CrashReports folder and there was no folder by that name. I did locate the SystemInformation.txt and Log.txt files. The Log.txt file is empty. The SystemInformation file lists my hardware and software configuration.

 

Where do I obtain a list of REQUIRED hardware for the product to perform properly? Is there a utility available that checks for missing or incorrect required items? This would be handy to compare against the SystemInformation.txt file.

 

Additionally, I went to the Administrative Events and located the associated event for the crash. The General tab contents are:

 

Faulting application name: Photo.exe, version: 1.5.0.45, time stamp: 0x58480606
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000007fe8a2909c6
Faulting process id: 0x139c
Faulting application start time: 0x01d26929ca47b13a
Faulting application path: C:\Program Files\Affinity\Affinity Photo\Photo.exe
Faulting module path: unknown
Report Id: 098c08bb-d51d-11e6-87ba-94de807fe43a

 

 

I requested more information for the Event Log from Online Help and after entering requested data was sent to this page:

 

https://social.technet.microsoft.com/search/en-US?query=Photo.exe%20Application%20Error%201000

Share this post


Link to post
Share on other sites

Lee D,

 

I took the system requirements from the product purchase page and have verified the following:

 

Memory (2GB RAM req'd) -  11+GB available at runtime

Hard Disk (670 MB req'd) -  108GB available on startup disk and 1.5TB available on data disk.

OS (64 bit req'd) -  Windows 7 Home Premium SP1 (64 bit)

Display (1280 x 768 or better req'd) - Current settings are 1920 x 1080 on dual monitors

Technology - DirectX 11 verified

                     Direct 2D is part of OS

 

Current GPU processor is NVIDIA GeForce GTX 780 with the following specs:

   Operating System:    Windows 7 Home Premium, 64-bit (Service Pack 1)
   DirectX version:    11.0
   GPU processor:        GeForce GTX 780
   Driver version:        373.06
   Direct3D API version:    11
   Direct3D feature level:    11_0
   CUDA Cores:        2304
   Core clock:        862 MHz
   Memory data rate:    6008 MHz
   Memory interface:    384-bit
   Memory bandwidth:    288.38 GB/s
   Total available graphics memory:    10950 MB
   Dedicated video memory:    3072 MB GDDR5
   System video memory:    0 MB
   Shared system memory:    7878 MB
   Video BIOS version:    80.10.36.00.01

 

The application still fails to start and no additional diagnostic information has been discovered. I proceeded through the process of re-installing the software. I chose the 'Repair Installation' option with no success.

 

Please advise regarding additional troubleshooting actions that I can take.

 

Thank you.

Watcher

Share this post


Link to post
Share on other sites

Greetings Lee D,

 

Additional efforts allowed me to open the AppCrash_Photo.exe file which I saved as a txt file.

 

Review of the file contents shows that Affinity Photo\Photo.exe is correctly installed in the 64 bit folder 'Program Files' however, the program is loading modules from \Windows\SYSTEM32\  , the 32 bit filesystem.

 

Can you assist on what actions are necessary to direct the program to load the dynamic link libraries and other binaries from the correct Windows directory?

Are there specific actions that I need to take during the installation process to ensure the correct path(s)?

Is there a configuration setting that I am not aware of that requires corrections?

 

I have attached the AppCrash_Photo.exe file for your review.

 

Thank you.

AppCrash_Photo.exe-01042017__Watcher.txt

Share this post


Link to post
Share on other sites

Hi Watcher,

 

You don't need to redirect the program to load from any specific folder, the installer puts all the files in the correct location.  The only other app so far we know can cause Affinity on Windows to crash on startup is FastPictureViewer Codec Pack, do you have this installed? If so if you update to build 3.8.0.9, it should allow Affinity to open.

 

Another option would be to do a clean boot in Windows 7 and see if anything else that's starting with Windows is causing the issue.

Share this post


Link to post
Share on other sites

Greetings Lee D,

 

I do not have FastPictureViewer Codec Pack installed to my knowledge. I have attached the list of Audio and Video codecs installed on my system.

In reviewing the file I noticed the first four Audio codecs have the same Version number, indicating a Pack. The last four Audio codecs and the last five Video codecs also have the same Version number, indicating another Pack. The first five Video codecs also look like a set. This leaves five Audio codecs and one Video codec about which I cannot make a determination.

 

This leads me to the question: How and where can I find out what the latest version number of installed Windows 7 codecs?

 

 

I performed a 'Clean Boot' of my system with the following results:

The application did not run properly and crashed on startup.

While in the 'clean boot' I attempted a 'repair' of the installation with negative results.

While in the 'clean boot' I removed the application and re-installed the application with negative results.

 

I then started checking the computer management logs and while they were open I recreated the error. I have captured the three generated log entries in the attached file along with a copy of the error Report.wer file.

 

Hope this is helpful to the support and development teams to help understand and resolve this issue.

 

Thanks.

post-48122-0-19279700-1484195042_thumb.jpg

Affinity_Photo_Crash_Data-Watcher-01112017.rtf

Share this post


Link to post
Share on other sites

Question:

What version of the Microsoft .NET Framework is required for Photo.exe to perform properly?

 

Research shows that Error Event 1026 is associated with .NET Runtime issues, as shown in the error logs that I provided. I inspected my system Windows features and the Microsoft .NET Framework is version 3.5.1.

 

Please advise if this needs to be updated to support Affinity Photo.

Share this post


Link to post
Share on other sites

Affinity Photo requires Microsoft .NET Framework 4.6.2 to be installed on the system. Use this link to download the offline installer direct from Microsoft.

 

With reference to accessing the System32 folder have a read of this page which also links to this one.

Share this post


Link to post
Share on other sites

Thank you.

 

The background information regarding the System32 folder usage was very helpful and cleared up my confusion regarding the binaries.

 

I followed the link you provided, downloaded the offline installer which 'repaired' the .NET Framework 4.6.2 installation on my system. I tried many approaches to determine what the installed version was on my system after the 'install'. (Just because I ran the executable, it doesn't guarantee the correct expected results.)

 

I tried several approaches to verify the version:

      '.NET Detector' did NOT correctly identify the installed versions.

     Traversing the Registry to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\full" only provides the Visual C# compiler version.

 

 

The solution was found by going to the page following this link:  https://msdn.microsoft.com/en-us/library/hh925568%28v=vs.110%29.aspx

 

     After traversing the path in the Registry using Regedit, look for the name 'Release', which indicates that .NET Framework of 4.5 or newer is installed on the computer. Using the Data value in parentheses at the end of the line, compare that with the DWORD table from Microsoft to determine the installed .NET version.

 

My system Registry shows the Release DWORD value to be '394806' which indicates that I have .NET Framework 4.6.2 installed on a Microsoft OS version other than Windows 10. [two files attached]

=====

 

An additional issue associated with starting Photo.exe was that I was getting a second 'Application Error' during program initialization. The Faulting application name was: NvStreamUserAgent.exe, version: 7.1.2084.9592.

 

Research on this executable revealed that it is an NVIDIA Streaming Service used by NVIDIA SHIELD owners to stream game titles. The service is setup to run automatically by default and it is said to lower your frame-rate by 3-5% when gaming. If you don’t have an NVIDIA SHIELD this service doesn’t need to be running all the time and you can disable it manually by following the guidance provided at:

      http://www.legitreviews.com/disabling-nvidia-streamer-service-gives-video-card-performance-boost_162524

 

I approached this as a "program conflict" and disabled the service.

This action removed the Application Error for 'NvStreamUserAgent' in the subsequent Windows Error Reporting log.

=====

 

I still am unable to execute Photo.exe successfully.  I continue to receive a 'System.NullReferenceException' in Windows Error Reporting.

 

Suggested next steps??

 

 

 

 

 

 

post-48122-0-02252700-1484861141_thumb.jpg

post-48122-0-83170500-1484861162_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×