Jump to content
You must now use your email address to sign in [click for more info] ×

Lens profile dropbox selector empty when developing RAW (MacOS, Apple Silicon)


Recommended Posts

Hi folks,

I have just discovered that, when developing RAW in Affinity Photo—under the Lens tab and under Lens Correction—the Lens Profile dropbox selector no longer works. It doesn't drop down and say Empty nor show all the lens profiles I'm used to seeing, rather it simply blinks quickly and does nothing. As such, I cannot see any lens profiles at all. I read about going to LensFun myself on github and downloading the XML files from there into ~/Library/Containers/com.seriflabs.affinityphoto/Data/Library/Application Support/LensProfiles/; I tried that and restarted Affinity Photo and still I see zero Lens Profiles. I also read that this may have to do with Apple Silicon rendering RAW files.

I am using Affinity Photo 1.10.8 on MacOS Sonoma 14.4.1 (23E224). I have tried with hardware acceleration on (Apple M3 Pro Metal) and off (software). The last time I used Lens Profiles was likely before I upgraded to 1.10.8 (but after 1.10.x) and before I moved away from my old Intel Macbook Air (which was November).

Thanks!

Link to comment
Share on other sites

  • Staff

Hi @JesseR,

Welcome to the Affinity Forums & thanks for your report!

I can confirm this is a known issue in Affinity V1 on macOS Sonoma - unfortunately with the Sonoma update, Apple broke the “pull down” variant of NSPopupButton, which the Affinity apps use for this dropdown functionality.

This issue with the NSPopupButton was reported to Apple when our team discovered the issue, but unfortunately has not yet been resolved within an update to Sonoma.

I have informed our development team that this issue still exists within Affinity V1 and requested to re-inform Apple, in the hope they will have this resolved shortly.

Affinity V2 apps use a different variation of NSPopupButton, meaning this does not occur in Sonoma for the latest V2 updates of Affinity, however I do understand this does not change the behaviour you experience in V1.

Please accept our sincerest apologies for any inconveniences caused due to this, as unfortunately I'm not aware of any workarounds for this at this time.

Please note -

I am currently out of the office for a short while whilst recovering from surgery (nothing serious!), therefore will not be available on the Forums during this time.

Should you require a response from the team in a thread I have previously replied in - please Create a New Thread and our team will be sure to reply as soon as possible.

Many thanks!

Link to comment
Share on other sites

Hi Dan,

Thanks for your prompt reply. Hopefully there are not many other instances of NSPopupButton that I have yet to encounter; the Lens Profile one is not as day-to-day important to me as some other dropdown selectors, e.g., Scope selector on the Scope tab. That dropdown selector, along with others I'm quickly looking at now, are working fine; they must not be instances of NSPopupButton. One solution perhaps could be an Affinity 1.10.x patch that changes Lens Profile from NSPopupButton to whatever dropdown selector Scope (and others) is using?

Cheers!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.