Jump to content
You must now use your email address to sign in [click for more info] ×

Affinity Photo 2.2.1 not starting on Win11


Recommended Posts

Hello, today I tried to launch Affinity Photo 2 on my win11 pc after a few weeks not using it, but it fails starting: when I double click the icon the cursor shows something going on for a few seconds and stops. I had versione 2.2.0 and tried to update to version 2.2.1 but nothing changed (I install from .exe files). The PC is less than 2 months old, but when I tried Photo after moving from the previous pc it worked without problems.

These are the specs of my pc

Nome dispositivo    DESKTOP-9N5AJDO
Processore    AMD Ryzen 9 7940HS w/ Radeon 780M Graphics        4.00 GHz
RAM installata    32,0 GB (27,7 GB utilizzabile)
ID dispositivo    0A65E070-B7D9-4FC1-AAC3-DF9A50C118A3
ID prodotto    00331-20313-72854-AA573
Tipo sistema    Sistema operativo a 64 bit, processore basato su x64

Edizione    Windows 11 Pro
Versione    23H2
Data installazione:    ‎06/‎09/‎2023
Build sistema operativo    22631.2715
Esperienza    Windows Feature Experience Pack 1000.22677.1000.0

Graphic card driver is the original AMD included in AMD Software Adrenalin Edition 23.11.1

I found some crash dump files named "Photo.exe.xxxxx.dmp" with xxxxx a number under the folder %USERPROFILE%\AppData\Local\CrashDumps (the path is different from the one you mention in this post

) and I attach the last one that was generated, hope this helps to understand and solve the problem.

Can you help me?

Thank you



Link to comment
Share on other sites

I have after the 23H2 win11 also some hangs or 100% system crash with the regulair 2.2.1.xxx version.  
I have also the newest beta 2.3.x.xxxx and have no problems. So I think is related to 23H2

Windows 11 (Home)-build: 23H2- build 22631.2715
-  64 bits. 
11e generatie Intel(R) Core(TM) i7-11700K @ 32,60GHz.
Ram: 80 GB  DDR4 -3200 Mhz-  34" breedbeeld
GpuGeforce 3060 -12GB  OC-studiodriver: 537-58 - XP-Pen star03 -
mastodon.nl /@digitalvisuals - website:  digitalvisuals.nl

Affinity Photo2 - Designer 1.10-  Publisher 1.10 - ArtRage 6 - Lumina Aurora - ArtRage.

Link to comment
Share on other sites

Hi again, I tried to update to version 2.3 but the result is the same: the program fails to run and a new dump file is created.

I also tried to uninstall completely the program and to reinstall it, both in the default suggested folder and in a "non standard" one I generally use to install programs,in both cases the result was the same.

And last, I've tried to change antivirus (sometimes they are responsible for similar problems), but nothing changed.

I'm running short of ideas..


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.