Jump to content
You must now use your email address to sign in [click for more info] ×

[Publisher 2.1.0] Document Information Fields (Author, Title, etc.) cannot be edited when file was migrated from V1 (?)

Recommended Posts

Can't edit the Document Information Fields like Author and Title. Whenever I save the document, it goes back to the original Author and Title when the file was V1.

I'm just guessing it might be because it was an old V1 file, but that's the only difference between files that have working fields, and files that don't have any.

  1. What Application are you using? [Designer/Photo/Publisher]
    • Publisher
  2. Are you using the latest release version?
    (here's how to check)
    1. 2.1.0
  3. Can you reproduce it?
    (if you cannot then we may struggle to also, making it even harder to fix)
    1. Use an old file perhaps? I will attach a sample file here.
  4. Does it happen for a new document? If not can you upload a document that shows the problem?
    1. Nope. Document will be attached.
  5. If you cannot provide a sample document then please give an accurate description of the problem for example it should include most of the following:
  •    What is your operating system and version (Windows 11, OSX Ventura, iOS 16 etc)?
    • Windows 11
  •    Is hardware acceleration (in Preferences > Performance) ON or OFF ? (and have you tried the other setting?)
    • ON. Haven't tried OFF.
  •    What happened for you (and what you expected to happen)
    • I want to edit Author and Title, but it doesn't work upon saving the document.
  •    Provide a recipe for creating the problem (step-by-step what you did).
  •    Screenshots (very handy) or a screen capture/video.
  •    Any unusual hardware (like tablets or external monitors or drives that may affect things) or relevant other applications like font managers or display managers.
    • N/A
  •    Did this same thing used to work and if so have you changed anything recently? (software or hardware)

Document Info Fields.afpub

Link to comment
Share on other sites

I just came across this issue myself (Windows 10 here) and wanted to post it. But while recreating it step by step, I found that you have to confirm every field change by pressing the Enter/Return key. Then the data persists and gets saved.

It still is a somewhat misleading behaviour. If I tab from one field to the next I can enter all the information but it gets lost on saving. This doesn't only apply to v1 documents opened in v2, by the way. This seems to be the general behaviour in v2.

Link to comment
Share on other sites

  • Staff

Hi @Seraguithand Welcome to the Forums,

We are aware of this issue and have it logged with the Developers to resolve.  As @thoroehas stated, the change will be accepted if you press Enter/Return after editing each field.

I've updated the report with a link back to this thread so we can update here when it's been resolved.


Link to comment
Share on other sites

  • 2 weeks later...
  • Staff

The issue "Fields Panel- clicking into each field and changing the contents without pressing enter causes the fields to clear when enter is next pressed in a field" (REF: AFB-7746) has been fixed by the developers in build "".

This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions

If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.