Jump to content

Publisher Exported PDF file is corrupt


Recommended Posts

The file correctly displays the textg as "Definiton of Vaheguru is adulteration".

But the selected text of this is "Defini�on of Vaheguru is adultera�on". I am using PDF Xchange Editor. 

Similar "Defini􀀐on of Vaheguru is adultera􀀐on" happens in Acrobat Reader DC.

This gives problems when searching for text.  Kindly help.

Link to comment
Share on other sites

The Affinity (one page of a large 27 page document) and PDF files are attached. 

The font I am using is Arial for the page attached plus Calibri (which gives the same problem) for other pages.

Yes you are correct it appears "ti" ligature.  How do I solve this and other similar problems.

Thank you.

220519 Hijacker of Sikhi V2 AFFINITY.pdf 220519 Hijacker of Sikhi V2 AFFINITY.afpub

Link to comment
Share on other sites

The Calibri ligatures export fine for me. Here's a capture from Adobe Acrobat Reader:

 image.png.42a2be116d34c9202645b679e5241ced.png

I don't have the GurbaniAkharHeavy font installed so I can't check if this has a side-effect.

Link to comment
Share on other sites

On 5/20/2022 at 9:41 PM, Harnaak said:

But the selected text of this is "Defini�on of Vaheguru is adultera�on". I am using PDF Xchange Editor. 

Similar "Defini􀀐on of Vaheguru is adultera􀀐on" happens in Acrobat Reader DC.

This gives problems when searching for text. 

I am guessing (again) that "selected text" means you are trying to copy this text from the PDF.
Affinity apps do not properly encode ligatures in PDFs.
So search does not work properly, and copy/paste does not work properly.
The only work-around is to disable ligatures.
In the Calibri font the ti ligature is in the Standard Ligatures.
So disable Standard Ligatures in the Typography panel.

Link to comment
Share on other sites

12 minutes ago, LibreTraining said:

The only work-around is to disable ligatures.

Turning off the Export option to Subset Fonts sometimes helps with the ligature issue, too.

image.png.2286bf06755aaa7d0ec8b19f282260b2.png

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.4.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

4 hours ago, LibreTraining said:

Do you have an example where this helped with ligatures?

Not a specific one, no, but it's been mentioned before.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.4.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

Posted (edited)

Thank you all for the help.

Walt Farrel: I have turned ligatures off (Text>Ligatures>Use None).  And "Export Settings>Subset  Fonts" checkbox unticked.  The problem still persists.  Maybe I have turned off ligatures incorrectly.  Is there another way to turn of ligatures.  I do not need ligatures.

Paul Mc:  Gurbani Akhar Heavy font attached.  Since you do not have this issue, there must be some setting that I could set to eliminate this problem.  Have you any ideas.

The problem this issue created is that the PDF created will have search issues.  On search any word with "ti" will not show up in the search result.  This is not good especially since I am distributing the PDF and the reader might search a word and miss out on words with "ti" in them.  That is how I found out the problem.

For me this issue is a big problem.  A resolution is really appreciated.  Further I wish to add that this problem did not exist previously ... I checked an exported PDF I prepared in March this year.  So it must have come up in the latest update.

GurbaniAkharHeavy.ttf

Edited by Harnaak
Link to comment
Share on other sites

@Harnaak I think I may have misunderstood the problem here. The font made no difference to what I was seeing. Here's how I turned off the ligatures:

image.png.c7b400633af11d2b46f9586e69dda885.png

image.png.d28248dabfd894f822b09a9482ea7eaf.png

The Typography panel can be found under the Character tab/studio. Toggling the fi button is all that was required.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.