Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Layers glitched out, has anyone seen this and is there a way to fix it? (1.9.3 MacOS BIG SUR)


Recommended Posts

Hey I had something crazy happen with infinity designer.. I was using the Fill Tool on my m1 Mac (Metal turned off) and it started getting suuuuuper lagggy, and 5 minutes later my mac told me I had 0 storage left. I checked and found that affinity dropped a 141 GB file into my Mac's private file storage! I resolved this and continued to use the fill tool which lagged a bunch, then poof! Half of my layers started glitching out, they either disappeared or leave weird glitch marks. As i move around the software they dip in and out, but remain gone 90% of the time, Im wondering if there is a way to fix this? I tried exporting and opening the file on an intel Mac. Same issues. Guess the file is "corrupted" even though the layers seem to technically still be there. If anyone has a fix for this or any ideas let me know!

Thanks

Screen Shot 2022-05-15 at 7.03.07 PM.png

Screen Shot 2022-05-15 at 11.24.34 PM.png

Screen Shot 2022-05-15 at 11.31.11 PM.png

Screen Shot 2022-05-15 at 11.31.26 PM.png

1872750970_ITISYOURBIRTHDAY.afdesign

Edited by quennythegr8
spelling
Link to comment
Share on other sites

  • Moderators

Hi @quennythegr8,

Welcome to the Affinity Forums & sorry to hear you're having trouble!

I can certainly see the corrupted pixel layers in your documents, it's likely the app was trying to write and read this pixel layer to memory, but when it became corrupted it continued to do this multiple times, filling your RAM and then 'overflowing' to a temporary file on your hard drive, until this was full also.

Can you please confirm for me:

  • Which Layer were you using the Fill Tool on?
  • What were you using as the Fill? (ie solid colour, gradient, bitmap?)
  • Do you have any previous backups of the file, where this issue does not exist?

Many thanks in advance!

Link to comment
Share on other sites

Hi @Dan C,

I like your profile pic btw,

- I was doing the Fill Tool on the black balloon pictured above, the layer is titled: "Black Balloon" within the "Black Balloon Group".

- The colors used were black to white on the radial setting for the Fill.

- I do not know if affinity keeps back ups or old saves on its own? If it does definitely let me know! I did not save a backup myself.

Thank You!

 

Link to comment
Share on other sites

  • Moderators

Thank you :)

I appreciate the confirmation - I've tried repairing the file using the methods available to me, however unfortunately I've been unable to, so I will be logging this file for further investigation with our developers.

59 minutes ago, quennythegr8 said:

I was doing the Fill Tool on the black balloon pictured above, the layer is titled: "Black Balloon" within the "Black Balloon Group".

How were these objects created/added to your design please? I can see each balloon object is 2791 DPI, which may be the cause for pixel corruption when editing such a high resolution object.

1 hour ago, quennythegr8 said:

I do not know if affinity keeps back ups or old saves on its own? If it does definitely let me know! I did not save a backup myself.

No problem at all, the app should make regular backups of the file, so we may be able to recover it this way. If you open Finder and navigate to:

~/Library/Containers/Affinity Designer/Data/Library/Application Support/autosave/

Do you have any files listed here? If so, simply rename them from .autosave to .afdesign and then open the file in Designer.

Are you able to recover the document using this method?

Also, I have just noticed in your title you are using version 1.9.3, which was released in April 2021 and the latest version is now 1.10.5 - is there a reason you are using an outdated build?

Link to comment
Share on other sites

Hello,

Unfortunately the only backup was the corrupted file!

I use my other computers for affinity as opposed to this m1 mac, so the version I had was the version since I downloaded affinity designer originally.

The balloons were created in a separate tab within affinity designer, then copied and pasted over to my main project. I used a png of a balloon from the internet.

It is worth noting that although the corruption happened during the fill tool on the balloon in the main project, there was lag that was picking up when creating the balloons in the second tab. The lag was gradual and I assumed it was just from affinity not being polished yet for the m1 transition. I did not imagine that the software would be able to fill my storage so I worked through the lag without realising what was happening. I was mostly messing around with the fill, pen, and selection tools. Fill caused most all of the major lag I feel like, I assume it would be more resource heavy. 

During the project when working on the balloons, I turned off metal acceleration, switched to OpenGl, and increased ram usage limit to mid.

I guess I will have to rebuild, oh well! "There are those who lost, and those who will lose", that is the nature of working on computers.

Thank you for the help!

 

Edited by quennythegr8
Link to comment
Share on other sites

  • Moderators

Thanks for trying that for me and I'm certainly sorry to hear this.

I have logged this file and the further information provided with our developers for them to attempt a repair using their further tools, however unfortunately this can't be guaranteed, my sincerest apologies.

I would recommend updating to the latest version of Affinity Designer through the App Store before creating your new document, as the latest version contains improvements and updates for app-stability.

Should our developers be able to recover this file, I'll be sure to update you here :)

Link to comment
Share on other sites

More News!

@Dan C

This time my storage was fine, but other areas took a hit.

It is definitely triggered by the fill tool, I used it twice on one of the balloons and boom! "System out of application memory" 49.49 Gigs!!!!

This is on the updated 1.10.5 affinity designer, I did not update my OS as it said an error when I tried.. Perhaps my issues are more internal, I will try to update the OS when I get a chance.

*EDIT* Yep, same issue on latest Affinity and Mac OS. It triggered once again while using the Fill tool. Took up 10gigs of disk space and 50+ gigs of application memory.

Hope this info helps,

thanks again!

Screen Shot 2022-05-16 at 3.05.37 PM.png

Edited by quennythegr8
Link to comment
Share on other sites

  • Moderators

Thanks for the update - as mentioned previously I suspect this is due to the incredibly large DPI value for these pixel layers.

When using the fill tool, the app has to calculate and render a very large number of pixels for this object, due to the aforementioned DPI value.

Before using the Fill Tool on this object, right click it in the Layers Studio and select 'Rasterise & Trim' - this will rasterise the image to your document DPI, in the file you provided this would be 300DPI, significantly reducing the pixel calculation -

Does this stop the app from ballooning the RAM usage? (excuse the pun :D)

Link to comment
Share on other sites

The Rasterize and Trim function had helped, but I still am having large writes to my storage and freezing up. I think Im narrowing it down to changing the color on the Fill color wheel. I assume that takes a lot of resources to shift colors, but enough to cause issues after rasterizing?

Link to comment
Share on other sites

  • Moderators

Thanks for letting me know and I'm sorry to hear this. Just to confirm:

  • Are you still using 1.9.3 as indicated in your title, or is this occurring in 1.10.5 (the latest version)?
  • Are you finding this issue occuring in a new document, or are you still editing the corrupted file provided to me?

If possible, could you provide a quick screen recording showing the exact steps you're taking, so I can better understand your workflow?

If you're unsure how to take a screen recording, please check out our FAQ linked below - 

Many thanks for your continued patience here :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.