Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

File corruption with groups containing embedded files


Pybewl
 Share

Recommended Posts

So I had this multi-hour, intricate project with dozens of images, shapes, nested groups, and an embedded designer file. I had double tapped it to open it and make a few tweaks. I then left things as they were, with the embedded document still open, as I had to switch tasks and work in different apps entirely, which caused AP to be dumped out of ram. Upon launching AP again I noticed that the thumbnail of my project was replaced by one of the embedded designer file. When I tried to open it, AP returned an error message that said « loading failed. Unable to load document. » 

I have tried relaunching AP, rebooting the iPad. No effect: the document still won’t load. So I guess the file is permanently corrupted.

 

Next, I experimented a bit. I have tried duplicating the document. Nothing happened. Trying to save it caused AP to just instantly crash. Renaming did work, but I still wasn’t able to save or duplicate the renamed document.

I also created a new document that contained the same embed and a couple of dozen pictures to very roughly mimic the original project and tried to reproduce the bug. I managed to get AP dumped out of ram while the embedded document was open, but after relaunching AP, the thumbnail was the one of the project, and there was no corruption.

Finally I stashed the embedded designer document in a nested group and tried again. Upon relaunch I was greeted with a thumbnail of the embedded document instead of one of the whole project. The document was corrupted: unloadable, unsavable, etc…

Edited by Pybewl
Grammar, clarity
Link to comment
Share on other sites

  • Moderators

Hi @Pybewl,

Thanks for your report and our sincerest apologies to hear that your work was lost.

In order for us to log this with our developers, I'd like to replicate this issue here with a copy of your files - can you please upload a copy of the .afphoto file and the embedded document to the below link for me? (note I am looking for a working version of the file before it is corrupted)

https://www.dropbox.com/request/R1BoM9sMDk0PdhbdGjxC

Once uploaded, please reply here to let me know. Many thanks in advance :)

Link to comment
Share on other sites

Hi Dan, thanks for your answer!

I have uploaded placeholder files after successfully reproducing the bug with them. I have managed to corrupt the AP document 3 times over a dozen or so tries. At this point, my hypothesis is that the faster you saturate the iPad’s ram, the higher the chance the document will end up corrupted. I don’t know if the autosave interval has an effect on this. Mine is set to 30.

 

Here are the steps I followed:

1) make a copy of the document and open the copy

2) in the layers studio, open the embedded svg file

3) (optional, I think?) change the luminosity of an element of the svg file

4) Launch a bunch of apps

Hope this helps!

Link to comment
Share on other sites

  • Moderators

Thanks for your files and further information provided!

I had tried replicating this here multiple times and I was unable to do this, until I changed my auto-save frequency.

I believe the app is auto-saving in an incorrect state (within the embedded document) and not correctly 'closing' from this file when entering the forced 'snooze' state that iOS applies, after opening multiple other apps.

I've been able to create a screen recording of this and therefore I'm logging it with our developers now, many thanks for your report :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.