Jump to content

File Corruption with M1 Mac Mini

Recommended Posts

We are a print shop that produces a lot of content and we recently decided to start testing an M1 Mac Mini with Affinity in a production environment. With the change of architecture we knew this may not be exactly perfect but with Serif doing such a good job on the transition we thought it would be a good time to start testing.

There are a couple things that are glitchy and one that is a showstopper.

1. Glitchy: placed PDFs will randomly disappear on the screen. They are still there in the resource manager they just show blank.

2. Showstopper: Lots of file corruption every day. A book that was worked on all day will suddenly become corrupt and cannot be opened. Even if it worked all day long, saved and closed, the next day it will be damaged when we go to open it.

The environment is this:

All computers are connected on an ethernet LAN to Mac Server where files are backed up using Time Machine and offsite cloud storage.

We have never had an issue until the M1 with file corruption and now we have it multiple times per day. The intel macs still have no corruption issues. Anyone else seeing anything similar?

This morning I am switching out ethernet lines just to see if that might be the problem. Next I'll see if working directly from the cloud (dropbox) would be better since it has to download a local copy to work on.

I am wondering if these issues are specific to our M1 and we have a bad model or if there is something else going on that we can address this quickly.

Link to comment
Share on other sites

If you're able to publicly share a PDF that will disappear randomly when placed, a few others of us with M1 processors could test it out to see if we see something similar.

I've never experienced file corruption with my Affinity files. There are often warnings about using cloud services with Affinity but I use iCloud over wifi and have never had a problem. Given there are issues with cloud services, I think looking at your network as a possible issue is worthwhile. It's odd that it impacts your M1 Mac and not the others though.

It will be nice when you've sorted these issues out - Affinity is blazingly fast on an M1.

Affinity Publisher/Designer/Photo 2 for macOS Ventura 13.2, MacBook Pro 14" (M1 Pro)

Link to comment
Share on other sites

Hi Mike,

I think it was that particular ethernet cable. We have not experienced any of the glitches, corruptions or the random slowdowns since replacing the cable. The thing that is probably the easiest thing to change is probably also the easiest to overlook. The computer has been running much better. You don't really think of a cable as wearing out or causing random glitches.

if anything reverts back, I'll inform, but so far it seems very fast.

The first clue that this was a unique issue was no one responded. If M1 was a problem there would be many people saying they ran into something similar.

thank you for getting back with me!



Link to comment
Share on other sites

  • 4 weeks later...

I hate to report but this is still happening. 

Went nearly two weeks with no problems then last Monday file corruption. This week switching to wifi only to see if that helps. I have noticed that it will go through times where it disconnects and reconnects repeatedly from ethernet saying unplugged even though it is not. This computer is rebooted daily.

This M1 still has placed PDFs that are blank on screen - print fine though.

My next test will be to run it using our files in Dropbox to see if local has any issues. I'm just not sure if this is just a faulty Mac or something else.

Link to comment
Share on other sites

  • 2 months later...

I believe we have figured this problem out. It's in the Mac Mini's themselves. We bought a second M1 Mac Mini and it had the same issue and was connected directly to the network - no wall wiring. What happens is that after a while the network on the computer seems to lose packets and then loses it's connection to shares even though it shows connected. The issue is with the network adapter and how it works in automatic mode on IP6 DNS configuration. If you have it set to automatic it will eventually run out of a cache space in the configuration as it continually tries to update it's status.

The solutions seems to be this:


I believe you can set it to Manually or Link-Local only and it will fix the issue (click apply or ok). Yesterday was the first day of heavy usage (newspaper day) and it never had one issue with it stuttering or network responsiveness and we had no files close.

These files get relatively large - on average 300 MB - and we don't embed anything - so this was a good sign. This was successful on both M1 Minis that were exhibiting the issue. I may change it on all of our computers.

Hopefully this will help anyone else that may be using these computers on a network.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.