Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Recommended Posts

Hi,

I found a bug or a strange behavior when using the Paint Brush Tool in Pixel Persona in Affinity Designer on the Mac and on the iPad app. I found this behavior even in Affintiy Photo on the iPad so I am afraid it is a feature rather than a bug ;)

When using the Paint Brush Tool in Pixel Persona on a newly created pixel layer and there are no other pixel layers visible a strange behavior is showing: The first stroke is not showing until I stop drawing and hover over the areas that I have drawn on. With every stroke that I draw outside of the previously touched areas the drawing shows missing artifacts and I have to hover over or zoom a bit to make the drawn visible.

A work-around for this behavior is to have a fully covered pixel layer under the new layer. Then the frist stroke on the new layer is shown instantly – as you like it as designer.

I attach a video of that behavior and the afdesign-file.

I use ADe 1.10.1 on a MacBookPro13,3 with macOS 11.6 and ADe 1.10.2 on an iPad Pro 10,5 with iOS 14.8.

I like Affinity Designer a lot – it' a great app for my purposes – and I hope this bug gets to be fixed soon.

Cheers!

FipsMusica-test.afdesign

Link to comment
Share on other sites

  • Moderators

Hi @1fips,

Thanks for the screen recording.

Does this happen with all brushes or only the ones shown in the recording?

One thing to try, go into Preferences>Performance and at the bottom of window is an option for Enable Metal Compute, untick this, restart Affinity and try using those brushes again.

 

Link to comment
Share on other sites

Hi @stokerg,

Thank you for the quick response.

This happens with other (standard) brushes too … I haven't tried all ;)

And the disabling of that Metal option and the restart had no effect. BTW I have the same behavior on the iPad app and in Affinity Photo too.

Link to comment
Share on other sites

  • 8 months later...
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.