Jump to content
You must now use your email address to sign in [click for more info] ×
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Hyphenation not working in Dutch in Publisher


Recommended Posts

Hyphenation is not not working for Dutch in Publisher on my Apple computers.

I use MacOS Big Sur version 11.6 and Mac OS Catalina version 10.15.7. My Publisher version is 1.10.1.

When I use Pages it is possible to use hyphenation without installing and using the Hunspell dictionaries.

All I have to do in Pages is to activate hyphenation, Klik on the Document icon on the toolbar (right side) and activate Hyphenation at the bottom. It works for Dutch and English, i only tried these languages. The Hyphenation dictionairies are already present in the Mac OS.

Is it possible to use this option also in Publisher?

Link to comment
Share on other sites

In Publisher, Spelling and Automatic Hyphenation are controlled by the Language specification in the Character panel (or Text Style) and the Use Automatic Hyphenation setting in the Paragraph panel (or Text Style) and the associated hyphenation settings there. So I would start by looking in those locations to make sure the settings are appropriate.

If that doesn't help, I would suggest following the steps in the FAQ and installing the hyphenation dictionary as shown there:

 

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

I have it working now. 

I used the help text in Publisher (see below). Then changed the Language specification in the Character panel and used Automatic Hyphenation setting in the Paragraph panel. I think I the format of my downloaded Hyphenation file was wrong.

 

Managing hyphenation dictionaries

Hyphenation dictionaries are included for most languages supported by Affinity apps, except for Chinese, Japanese and Russian. New hyphenation dictionaries can be downloaded and installed manually.

To download a hyphenation dictionary:
  1. Go to LibreOffice's GitHub page.
  2. Select the folder for the required language.
  3. Select the file for the required hyphenation dictionary. Its name will be in the format hyph_xx_XX.dic, where xx_XX indicates the language's locale ID.
  4. Depending on the file's size, you will see either a Raw or Download button. Hold  and click the button to download the hyphenation dictionary.
  5. If your browser appends an additional file extension, e.g. .txt, to the download's name, remove that extension so the filename ends with .dic.
To install a hyphenation dictionary:
  1. In Finder, hold  and select Go>Library.
  2. Open the Spelling subfolder.
  3. Create a subfolder and name it after the hyphenation dictionary's locale ID, i.e. where the dictionary's filename is in the format hyph_xx_XX.dic, the subfolder should be named xx_XX.
  4. Place the hyphenation dictionary in the subfolder.
  5. Quit and reopen Affinity Publisher.

The newly installed dictionary is available in the Hyphenation pop-up menu in the Character panel's Language section.

Link to comment
Share on other sites

  • 4 months later...

When I install hyph_nl_NL.dic, nl_NL.aff and nl_NL.dic in a folder nl_NL which is inside the spelling-folder in mypersonal library on MacOS 11.6, I still have problems. Yes, I can select text and set it to be Dutch (which helps when spellchecking), Yes I can set Dutch hyphenation rules (which should help in getting properly hyphened words), but NOTHING happens when I activate Use auto-hyphenation. No hyphens whatsoever. I do get hypens when I set the hyphenation to German, but why not when I set it to Dutch? And worse of all: when I set the Hyphenation to Auto afterwards, Publisher CRASHES. 

By the way: can you set the default language of your text, in advance? I wouldn't want to set it to Dutch with every document I make. 

Link to comment
Share on other sites

20 minutes ago, Peter Maas said:

Yes, I can select text and set it to be Dutch (which helps when spellchecking), Yes I can set Dutch hyphenation rules (which should help in getting properly hyphened words), but NOTHING happens when I activate Use auto-hyphenation.

Possibly you downloaded the hyphenation dictionary incorrectly. You should be able to open it with a text editor, and when you do so it should look like plain text, not HTML code.

21 minutes ago, Peter Maas said:

By the way: can you set the default language of your text, in advance? I wouldn't want to set it to Dutch with every document I make. 

The default language is determined by some combination of the language you specify in your Publisher Preferences, General, for the User Interface Language and your Mac system settings. (It's a bit more complicated on Mac than on Windows, I think.)

Those determine (if it works like it does on Windows) the language specified in the Base text style, and in the Character/Paragraph panels. Other built-in text styles inherit from Base.

If you want some other language as the default for a document, you need to set it via those panels or via your text styles. You could update Base, for example, which would set it for the other text styles that inherit from it.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

Thanks, Walt,

you were right, on the matter of having downloaded the files incorrectly. I downloaded them again, from a different list or page, with Chrome this time (first time was Safari). This time I was on this url: 

About setting Dutch language as a default for my text on my pages: it seems that I can change the settings for Base in a document (right clicking on the style and edit it). Then I can use the hamburgermenu of the text styles panel, and choose to save styles as default. When I make a new document after that, the default style that will be applied to my new text is [no style] which still defaults back to English. When I first apply Body or any other style to my text, the language will be based on Base which is Dutch now. So yes, I can set my default language for text, but the default style [no style]that will be applied to new text is still in English. 

Edited by Peter Maas
Link to comment
Share on other sites

1 hour ago, Peter Maas said:

but the default style [no style]that will be applied to new text is still in English. 

You may be able to set the Languages for [No Style] in the Paragraph and Character panel and then use Edit > Defaults > Set from Selection ("Set" be be something else; I'm away from my computer), then Edit > Defaults > Save.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

  • 2 weeks later...
8 minutes ago, Peter Maas said:

it is possible to set [no style] to my according and set that as a default. Thanks for the suggestion. But I find it only applies to the current opened document. When I make a new document, it has jumped back to English. 

Did you do the  Edit > Defaults > Save  operation? that is what should make it apply to other documents that you create later.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.