Jump to content
You must now use your email address to sign in [click for more info] ×

Crash caused loss of all Assets

Recommended Posts

I frequently import and export Assets files as I use Photo for scrapbooking.  I often get a white line along the top of the screen and "not responding" which eventually sorts itself out and I can carry on.  Since the update a couple of weeks' ago not only have I had the "not responding" message but a crash of Photo.  Tonight I was deleting some Assets files from the panel and Photo crashed.  All Assets have been deleted.  I can't get them back from the Affinity shop because I've already downloaded them once.  Luckily I had created them into an Asset file in case this happened.  However, I thought I should report the problem anyway.

Link to comment
Share on other sites

Hi @Canterslowly Sorry to hear you have experienced crashing and your Assets were somehow removed.

Can you upload a video of the issue where you experience the while line and the "not responding". It would be helpful to see the kinds of situations where this happens and the steps to reproduce it. I'd like to try and recreate this issue to see if I can get it to delete Assets too.

Link to comment
Share on other sites

I tried to upload videos yesterday but they were stuck in a queue for ages.  I tried using Gamebar to video but it didn't capture the dropdowns or the bar across the top which signifies the not responding message.  I may have to just set up my phone on a tripod and do it that way - unless you can suggest recording software that I could download (I could do with some anyway).  

Link to comment
Share on other sites

Hi, thank you again for responding.  I've got a number of videos for you (if they upload this time).  Photo and Designer both were unresponsive, although I caused one of the Designer examples because I clicked on for a New File while the Asset was loading. I had to use Ctrl+Alt-Del on one occasion because it was stuck in a loop.   Publisher was OK - I'm not sure if it has actually had the unresponsive problem that I've noticed but I haven't used it much yet. 

Link to comment
Share on other sites

Oh, I also have the file sizes for the asset files I was using, that may help.

GTD Another Winter’s Tale – 358,791 kb

GTD Special Something – 298,004 kb

GTD Special Something – 433,013 kb

JMadd Creepy – 325,238 kb

Synergy Ink Into the Wild – 423,932 kb

Synergy Ink Fall Transfers – 103,503 kb

Link to comment
Share on other sites

Publisher was the only program that didn't go into "not responding" - until I'd finished videoing then it did it 4 times in a row.

None of the programs crashed totally or lost Assets through crashing.  So far, that's only happened once and the assets loaded through the Affinity updates were lost as well as my own.  (As mentioned I do have backups).

Link to comment
Share on other sites

That tells that it crashed in the libraster.dll library due to an read access exception ...


Operating system: Windows NT
                  6.2.19041 804
CPU: amd64
     family 6 model 158 stepping 10
     8 CPUs


Crash address: 0x38

Process uptime: 2385 seconds

Thread 0 (crashed)
 0  libraster.dll + 0x16c16ac

    rax = 0x000001b00dae6830   rdx = 0x000000000000003f
    rcx = 0x0000000000000000   rbx = 0x0000005bb2deb480
    rsi = 0x0000000000000040   rdi = 0x000001b02abe2bd0
    rbp = 0x000000000000003f   rsp = 0x0000005bb2deb3b0
     r8 = 0x0000000000000040    r9 = 0x0000005bb2deb3d8
    r10 = 0x0000000000008000   r11 = 0x0000005bb2deb1f0
    r12 = 0x0000000000000002   r13 = 0x0000000000000003
    r14 = 0x0000000000000000   r15 = 0x000001b02abcd280
    rip = 0x00007ffb978416ac
    Found by: given as instruction pointer in context
 1  libraster.dll + 0x16c15b3
    rsp = 0x0000005bb2deb3d0   rip = 0x00007ffb978415b3
    Found by: stack scanning
 2  libraster.dll + 0x1a7e01d
    rsp = 0x0000005bb2deb400   rip = 0x00007ffb97bfe01d
    Found by: stack scanning
 3  libraster.dll + 0x1995acd
    rsp = 0x0000005bb2deb430   rip = 0x00007ffb97b15acd
    Found by: stack scanning
 4  libraster.dll + 0xcc49f2
    rsp = 0x0000005bb2deb4d0   rip = 0x00007ffb96e449f2
    Found by: stack scanning
 5  libraster.dll + 0xd82d54
    rsp = 0x0000005bb2deb540   rip = 0x00007ffb96f02d54
    Found by: stack scanning
 6  libraster.dll + 0x20ea1e8
    rsp = 0x0000005bb2deb548   rip = 0x00007ffb9826a1e8
    Found by: stack scanning
 7  libraster.dll + 0xfed825
    rsp = 0x0000005bb2deb640   rip = 0x00007ffb9716d825
    Found by: stack scanning
 8  ucrtbase.dll + 0xfde6
    rsp = 0x0000005bb2deb6a0   rip = 0x00007ffc30cdfde6
    Found by: stack scanning
 9  librenderer.dll + 0x202c2fa
    rsp = 0x0000005bb2deb700   rip = 0x00007ffb955ec2fa
    Found by: stack scanning

Which version of Affinity Photo is used? - Try out the latest beta version, it may have already fixed this issue.

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.