Jump to content

Fontsize hyperlink doesn't update


Recommended Posts

I made a Publisher document with approx 450 hyperlinks.  When I change the font or bold/underline and update the character style all the links change.  When I change the size and update it doesn't work.  Is this normal?  I guess not.  A workaround?  I don't want change all 450 links one by one!

Link to post
Share on other sites

A possible reason & workaround: In this video both hyperlinks have a style assigned with its size set to [No change], so they get their size from the accordingly assigned paragraph style – but there the size of the link text is overwritten already, indicated by the + symbol. As soon I reset this paragraph style then the custom size of the hyperlink style becomes active:

Find & Replace should enable you to repair your 400 hyperlinks with its Format options set in Find AND in Replace. Maybe the easiest way is creating first a new, different named Hyperlink style and then replace the current with the new. – Before (and not in the video) I experienced in the Hyperlinks Panel that re-assigning the current style via its pulldown menu causes this specific single link to react on a previously changed size of the hyperlink style (which initially was automatically created by APub with my first link).

1941863741_hyperlinkcharstylesizefixFR.jpg.1265f8b6e3b087dabc0fe008fb8e9105.jpg

macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Link to post
Share on other sites
2 hours ago, Marcel5714 said:

Strange that updating the hyperlinks wouldn't work for the size.

In my example it may feel odd but doesn't feel entirely unexpected to me because I had overwritten already the size defined in the paragraph style. Then a change of "[No change]" in the character style has a conflict: should it apply only for those text which still has the initial ("not changed") size of the paragraph style – or should it be dominant and apply to everything?

Without an overwritten paragraph style a change of the hyperlink style font size appears to react immediately, with and without an applied paragraph style.

But this video shows another issue: the greyed out "Add hyperlink" button in the Hyperlinks Panel. Though it can be bypassed via menu Text > Interactive it feels like a bug. It doesn't happen continuously, I haven't noticed yet what situation triggers it. Nevertheless, at least in this new, very simple .afpub I would expect this UI to work properly.

macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.