Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

AP – issues selecting or creating a hard pixel edge


Recommended Posts

Good day, this seems like it should be simple but the solution eludes me. I do a lot of work with creating seamless textures. When I select, or create, a texture in AP I always end up with a 'faded' or aliased edge. Even turning off anti-aliasing in the selection settings and setting feather to zero does not prevent this from occurring. It's incredibly frustrating.

Any seamless textures I export, in any file format, always have a faded edge around them so that the tile edges are visible on any objects they are applied to in a 3D editor. The only way I have found to minimise this is to create multiple, identical layers in the file I wish to export and export WITHOUT merging them down.
 

When cutting and pasting textures or images every edge has a slight fade (1-2px wide) around it, so that tiled textures have a clear cross-hatching where the faded edges join. Again, there is a work around which requires me to jog the pasted image a few pixels in either direction to close the join and remove the fade, but then the original ratio is compromised and it requires me to resize the exported file back to the correct dimensions.

So, two questions. Why is this a 'feature' of a non-aliased, non-feathered selection and secondly, how the hell do I prevent it from happening all the time?

Thanks in advance.

Screenshot 2021-02-11 at 16.04.51.png

Link to comment
Share on other sites

For a straight, vertical line, (anti)aliasing should not be an issue, regardless of whether the antialiasing checkbox is selected or not.  This looks more like there is a feathered selection, if what your figure appears to show is partial transparency of the blue area butted up against the gray area.  What tool(s) or methods are you using to make your selections?  For example, if you use the Selection Brush Tool and have "enable soft edges" checked, it will affect the selection edges.

You probably need to explain more about what you are doing and what resolution your are working with.  Also, Windows or Mac?  I am on a Mac and this does not happen if I simply use the freehand selection tool to make a selection, copy it and paste it - the result is a hard-edged selection (anti-aliasing not enabled before making the selection).

kirk

 

Link to comment
Share on other sites

15 minutes ago, Lagarto said:

Please check that yuo have the Force Pixel Alignment button (the left one of the buttons framed below with a yellow line) turned on -- and optionally also the Move by Whole Pixel button. If it is not turned on and a pixel selection is moved anywhere else than exactly on the pixel grid (made visible below) the edges will be permanently antialiased, as shown below. This happens disregarding the kind of selection you have (antialiaised / feathered or not).

not_pixel_aligned.jpg.a03aec50c850fd7fe181e6ed24cbc08e.jpg

Perfect answer. It seems this was the issue.  Many thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.