Jump to content

Affinity Publisher Hyperlinking and including a PDF File on Export


Recommended Posts

Hello,

I have created a "button" icon of a PDF file that I wish to include inside an exported copy of a report that I am creating in Affinity Publisher (see screenshot).

  • I gave the PDF icon Hyperlink Properties: Hyperlink Type: File.
  • I pointed the hyperlink to where the file resides on my computer.
  • Finally, I check boxed "Include File on Export."

I then exported the Affinity Publisher file in PDF format. I have tried a few PDF formats for exporting:

  • PDF (for export)
  • PDF (digital - small size)
  • PDF (digital - high quality)

When trying to click the hyperlink on my work computer, I get the following message: "The file “FileName.pdf” couldn’t be opened because you don’t have permission to view it."  I tried giving full permissions to both the exported PDF and the linked file PDF but I still get the same message.

When I try to click the hyperlink in the exported PDF on another computer, nothing happens. I do not even get the message telling my I do not have permission to view it.

Could someone please help me by letting me know:

  1. What is expected behavior when we link a file in a PDF export and check box "Include File on Export."
  2. Please tell me what I am doing wrong.

Thank you in advance for any help and support.

I am using an iMac running macOS Catalina and the latest version of Affinity Publisher.

Screen Shot 2021-01-22 at 16.28.48.png

Link to comment
Share on other sites

What application are you using to view the exported PDF?

Have you tried another one?

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.6.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

Hi @walt.farrell,

I tried using both Apple's Preview app and Adobe Acrobat Pro.

Maybe I am misunderstanding the checkbox "Include File on Export". I was imagining that the file would be embedded inside the exported PDF. It seems like the file is simply copied and placed separately to the PDF export. If this is the case, then I might have to look for an online option such as through Dropbox.

Although it still does not quite explain the message regarding not being able to open the file due to lacking permissions. Thank you for your help!

Link to comment
Share on other sites

If it helps for investigation, the attached Zip contains 2 .afpubs + accordingly PDF exports. Each of them contains a set of the 5 available Affinity hyperlink types, with the link on the text "file" in both PDFs pointing to the other PDF.   (ignore "cross reference" in the file file name, in fact it's hyperlinks only)

hyperlinks cross reference.zip

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

Hi @thomaso

Thank you, this confirms it:

Quote
  1. (Optional) For a file link, tick Include File on Export to have Publisher create a copy of the file alongside the PDF (when exporting to a PDF version that supports hyperlinks).

Just one final question, does anybody understand why the message occurs: "The file “FileName.pdf” couldn’t be opened because you don’t have permission to view it." ?

Link to comment
Share on other sites

I don't really know but it feels like a macOS thing. A search for "macos preview open pdf link access right denied" shows a bunch of results, some in the Apple discussions.

I did not get this access rights message in Acrobat Pro – but right now I got it when trying one of my test PDFs in macOS Preview. Then I tried the other PDF first and the message doesn't occur again + the links work, now between both PDFs (... as if Preview.app would have to "learn" first, though it doesn't make much sense).

Do the links in my uploaded PDFs work for you? If yes then take a look in the .afpubs to compare the ways the links are set.

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

Hi @thomaso,

Yes, the links all work, thank you. I think you might be right. Some macOS security thingy. Although I cannot (for now) find a solution to circumvent it.

At this point it looks like the best solution for me is to put the linked PDF file online and allow people to access through a URL.

Thanks again for your helpfulness! 🙏

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.