Jump to content

Recommended Posts

Hi there. Not sure if I can find help with it, but want to share my frustrating experience.

While working with mutilayered file in Affinity Photo 1.8.5.703 on Win10, I established 3 correcting layers in separate folders - Shadows Highlights Halftone.

Shadows and Halftone folders had corecting layers inside (1 and 4 on screenshot) and Highlights has a filled with yellow paint layer in soft-light mode with mask inside (2 and 3 on screenshot) Last time I worked with this file was yesterday. I checked the results of my work and saved it. But when openinig this file today I found the layers 1 and 4 was completely black, all hand painted mask disappeared, layer 3 was light gray instead of yellow like before. But mask (3) is ok. I exclude the possibility of accidental or malicious damage - nobody switched on my laptop since yesterday, I checked this layers before closing and I can't believe that I could damage (eg fill with black) accidentally all three layers simultaneously. So, I assume there is a some bug in program.

PS I tried to find any possibility to restore previous versions of file and found that there is no autobackup option in Affinity, although there are user's requests of this option on forum from 2018. Instead of that there are recommendations to save manually. Well, thanks a lot. 

 

.

Screenshot_34.jpg

Link to post
Share on other sites

Document being displayed correctly according it's new status - correcting layers with whole black painted masks don't affect layers under it(1,4) and paint layer with existing mask affects like it would when it was grey. The problem is - when I saved it last time, correcting layers masks were not black and paint layer was not grey.

Link to post
Share on other sites
23 hours ago, dimetilamin@gmail.com said:

layer 3 was light gray instead of yellow like before. But mask (3) is ok.

Layer 3 in your screenshot is a mask, literally "(Mask)", right? In my understanding such a layer is supposed to appear in the layers panel in grayscale and painting on it gets done in grayscale, too. – Are you able to reconstruct a yellow "(Mask)" layer with any document or object?

16 hours ago, dimetilamin@gmail.com said:

whole black painted masks don't affect layers under it(1,4)

Isn't this caused by your layer hierarchy, the nesting of layers and groups and masks relative to colored image/pixel content? Note, also the blend mode of a "(Group)" layer can influence the affect of its containing adjustments, e.g. if set from "Passthrough" to "Normal". So it's hard to judge from your screenshot detail what exactly is going on or wrong. To me your describing text sounds to differ so much from the screenshot that I wonder whether they are related to the same document, in particular that formerly painted mask layer content disappeared or got replaced with full fill color. – If you like upload your document to enable detailed investigation by the community or a staff member.

On 12/25/2020 at 2:19 PM, dimetilamin@gmail.com said:

PS I tried to find any possibility to restore previous versions of file and found that there is no autobackup option in Affinity, although there are user's requests of this option on forum from 2018. Instead of that there are recommendations to save manually.

As a workaround you could save the history together with your document, this enables you at least to retrace the undoable steps of the workflow for various states of a document. You can activate it at any time before "Save" to make it work for the current + any future session. (menu File > Save History With Document)

macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.