Jump to content
TEcHNOpls

Strange bug with history

Recommended Posts

Unfortunately I can't find any specific scenario for this, usually this concerns new layers, with stuff being painted over them (regular, inpainting) with some undo thrown in. The only thing I'm most certain is that undo can cause this behavior.


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites

@Gabe to see the issue, just move back to the start of history, you will find that the selected (arrow with one line) layer is painted white a lot and it's empty at the end of history.

 

Also, try this:

1. Select 'black' layer (arro with two lines)

2. ctrl+click, nothing is selected

3. enable layer visibility and try the same, it should select properly now.

4. with the selection, make the black layer disabled, and select the layer directly below it

5. go to: edit -> fill, choose inpainting, notice that the UI kinda looses responsivness and waits for the "working' dialog to appear for a long time.

6. edit -> inpaint is much more responsive/fast

7. you can compare the results too as I felt they were different (also using inpainting brush+selection seems to give different results too).

 

image.png.1888e6e5e58fb75e9fec2c9922c0b806.png


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites

It's back. With a vengeance.

See the clips, the screen gets corrupted easily, and after one of these, I managed to damage the layer I was working on.

https://clips.twitch.tv/MagnificentFurtiveSoymilkArsonNoSexy-o9819aDCeYv6Q8YM

https://clips.twitch.tv/FrozenMildDadChefFrank-grv8kFOHEkZq4sH_

 


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites

I've been testing with OpenCL off, and besides some lack of responsiveness a few times, these Issues seem to be not happening in this case.


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.