Jump to content
Isaac Medina

iPad Affinity Photo developing without pressing the "develop" button

Recommended Posts

The App develops my photo without warning and without me touching anything.
The issue occurs in the middle of edits and the screen blinks and develops my photo prematurely when I'm not touching anything on the screen.

Device: iPad Pro 2018 12.9 inch 1TB
File: Fujifilm X-Pro 1 RAW file .RAF

Video: https://youtu.be/OlfIgFUOSTc

It's not a great video as I haven't used Affinity Photo in many months because of this problem, but the issue happens consistently, ie. every single time I edit a RAW file.
To just watch the issue, please watch: 2:52 and 12:16.

Share this post


Link to post
Share on other sites

Hey Isaac Medina,

I have never had this happen before nor have I seen it reported, but it does indeed look as though it is developing by itself. 

When it first happens, it looks as though you are dragging a slider and then it loses focus and the image is developed. 

Does it seem to happen after a while in the Develop Persona or can it sometimes happen after a short time?

Share this post


Link to post
Share on other sites

It can happen while I'm touching something, or not touching anything at all.
So yes, to answer your question, it can happen whilst not touching anything, but I am touching the Apple Pencil!? Could this be vital information?

Yes, I am always staying put in the Develop Persona and never shifting around to other personas.

Share this post


Link to post
Share on other sites

And I have two cameras.

I just noticed that the RAW files in my video are Uncompressed RAW RAF file from my Fujifilm X-T3, but the same problem would always happen with the X-Pro 1 RAF files.

Share this post


Link to post
Share on other sites

You aren't accidentally catching the develop with your palm are you? 

Can you try enabling 'Show touches' from Preferences and record yourself again and watch what touches might be appearing around the screen. Also, do you have 'Touch for Gestures' enabled in Preferences? That might stop some unwanted touches (if that is indeed what is happening here).

Share this post


Link to post
Share on other sites

I am having troubles finding the "show touches" in the preferences.
After some googling, I came to the conclusion that it may be in assistive touch, but I still can't find anything.

My hands are not touching the screen at all, but it may have something to do with the Apple Pencil as I got the problem to stop (once) when not using the pencil.
I will keep experimenting with this.

Where can I find "Show touches" on the iPad?

Share this post


Link to post
Share on other sites

Preferences > General > Show touches (second from bottom).

If you go to Preferences > General, do you have anything mapped to the double tap for the Apple Pencil?

Share this post


Link to post
Share on other sites

Chris, thank you so much for your persistence.
I originally thought you were talking about the Settings on the iPad and not within Affinity Photo, which is why it took some time for me to find it.
I confirmed that unforced touches were not an issue. The problem was the Apple Pencil and me putting the Pencil back on top of the iPad momentarily was registering as a double tap.
So that option has now been disabled.
I can't believe I put up with this problem for such a long time.

And I am by no means a novice, but I thought that my Apple Pencil preferences set in the Settings on the iPad would affect all Apps (unless overridden).
I had double-tap registered to "do nothing" in the iPad OS Settings.
I should have checked.
Again, thank you.

Share this post


Link to post
Share on other sites

I have had this happen several times, too.

i have a 2020 iPad Pro 12.9, the latest iPad pencil, and the latest Affinity Photo.

it always happens when I am in the Raw persona and am in the middle of applying a brush mask to a layer. I apply the mask, go to the Basic Studio and adjust the lighting of the masked area, sit back and look at the results, and then when I move the pencil tip toward the photo again to modify the mask, in the blink of an eye it Develops. Usually before I’ve even touched the screen with the pencil tip.

This doesn’t happen every time but a half dozen or so times in 5-6 photos. Starting over again is a real pain.

if you would add the ability to save intermediate results in the Develop persona, we would at least have a workaround for bugs like this one, but every time it happens I have to redo the entirety of the Raw changes I’ve made.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.