Jump to content

Recommended Posts

Posted (edited)

Good day

This may not be a bug, but it is a little annoying.

5 things:

1. When I select multiple objects, I am unable to hold in Shift and click+drag the selection tool to deselect the objects I don't need. I have to click on the individual objects. This technique is time consuming and very inaccurate. It would be a huge timesaver and userfriendly to just select multiple objects with the click+drag, and using the Shift key to deslect multiple objects at once.

2. Expanding strokes. Apologies for comparing this to another design software. Expanding strokes in Adobe Illustrator is way easier. I can simply select all objects on the paste board, and expand the strokes, and only the objects that had strokes will have their strokes expanded. However, in Affinity Designer, even the objects that didn't have strokes somehow gets invisible expanded strokes, which creates unnecessary nodes, uses extra computer resources and causes more unnecessary time consuming effort. I have to go to each "unstroked" object and first delete all those invisible expanded strokes. This leaves me with less room for creativity and makes me less motivated to use Designer, because I know that is the struggle I'll have to go through.

3. Aligning objects. I'm pretty sure this is a bug. In the beginning, I was able to select my objects and then select the option of how I want to align them, such as "first selected," etc. When I select my object, those options are grayed out. Currently, I have to first apply my alignment, then the options become available. It's not working properly. Can you also perhaps create a shortcut for "key object" so that the child objects will align to the parent object?

4. For some reason Designer starts to lag when a single object has a lot of nodes. I'm used to using as little nodes as possible, but sometimes a complex object involves plenty nodes. In this case, the program gets laggy. I'm running a SSD drive, with 12Gb RAM, GeforceGT 640m 2GB, and i5 processor. Illustrator runs very smoothely on my computer, so not sure why Designer stuggles.

5. This can be a future request: "Offset path." So useful!

I look forward to your feedback and hopefully resolving these bugs in the near future.

Edited by LJSwanepoel
Added a feature request

Share this post


Link to post
Share on other sites

Hi LJSwanepoel

1. This is an issue that has now been fixed by development and will be resolved in the next release.

2. Could you attach a document with some objects that give you 'invisible expanded strokes'? Just tried this myself and didn't get any extra objects when using Expand Stroke on an object without a stroke.

3. This is something that has been raised with development, but is an intentional change. Essentially the previous behaviour would have had buttons enabled for modes that wasn't always applicable, so you have to first select an alignment mode before you can set its options.

4. Do you have an example file you could attach?

5. Any feature requests please post them here: https://forum.affinity.serif.com/index.php?/forum/53-feedback-for-affinity-designer-on-desktop/

Share this post


Link to post
Share on other sites

2. Invisible new shapes as a result of Expand Stroke are created when source objects have a non-zero width stroke and no stroke colour or fully transparent stroke colour. 
That result can be avoided by using a zero width stroke instead of an invisible non-zero width stroke when an object is to have no stroke. Stroke panel includes a No Line Style button for setting the stroke width to zero.
It seems reasonable for you to expect Expand Stroke to produce no new object from an invisible non-zero width stroke. Maybe the developers will implement that if you suggest it in the feedback forum for Designer.

5. That's being worked on at the moment. An impressive WIP demo was posted by a developer not long ago.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.