Jump to content

Update to Affinity Photo 1.7.2 failed

Recommended Posts

When I started Affinity Photo, I got a message saying that 1.7.2 was available.  I downloaded it and attempted to update.  Got the message Setup Failed.

When I then tried to start Photo, it was missing and couldn't start.

So I deleted the downloaded file and went to download it again but I cant find a link to download it.

I get the same New Version Available dialog with Designer and Photo but I'm not willing to take a chance on losing them also.

How do I download Photo 1.7.2?


Dave Davis


Link to comment
Share on other sites

  • Moderators

There was no need to delete the downloaded file, simply restart the computer and run it again. Now it's gone you can redownload it from this link or by following these instructions taken from the Photo Windows 1.7.2 launch announcement. You will probably still need to restart before the installer will work.

"If you’ve purchased from the Affinity Store— each time you start the Affinity Store software it will check for updates and offer any available update. The latest update will install over the top of any earlier version, with no need to uninstall. You can download the latest installer by logging into the affinity store here and find the order in your account and use the "Download" button in there. Alternatively, this new release (and previous versions of Affinity Photo for Windows) can be downloaded from this link. (that installer is NOT for Windows Store purchases and needs a product key)."

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon


Link to comment
Share on other sites

Okay, when I tried to Update Photo, Designer, and Publisher, all updates failed


and then when I attempted to access the previous version of the update that had failed, I saw this


In each case, I was able to get things working with a restart of Windows.

I also note that when I initially attempted to Update, clicking on the update file began the process.

After the restart, clicking on the Update file brought up a dialog asking where I wanted to install.

I hope this will help anyone else having a problem with the update.

Kudos to Serif for getting back to me very quickly.  thanks guys.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.