Jump to content
You must now use your email address to sign in [click for more info] ×

PDF export from Designer -> shadow effect is rasterized and no longer a vector element

Recommended Posts

Hello all,

I designed a logo and used the outer shadow effect, Radius is set to 0 px. (see picture below)
My expectation was, when exporting this to a PDF x4, that this shadow still is a vector element. When zooming in the PDF file in Adobe Acrobat, I can see that the effect was rasterized.
In the PDF export preferenced, "Rasterize: Unsupported elements" is activated.
Switching this option to "Rasterize: Nothing" will result in a PDF file without any shadow.

Is there any way to keep effects as vector elements like in Adobe Illustrator?

Thanks for your hints!
I'm using Designer 1.6.1 on Mac OS X

Regards, Holger

Bildschirmfoto 2018-12-03 um 20.34.14.png

Bildschirmfoto 2018-12-03 um 20.37.16.png

☛ Affinity Designer 1.6.1 ◆ Affinity Photo 1.6.7 ◆ Affinity Publisher Beta ◆ OSX Yosemite

Link to comment
Share on other sites

  • Staff

Hi MacHolgi,
Welcome to Affinity Forums :)
All layer effects are raster based and scaled/transformed dynamically with the objects. On export they are rasterised according to the dpi specified in the Document Setup dialog, so there's no way to export them as vector elements.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.